5

I would guess it is likely an issue with domain name and/or HTTPS conflicts. In your civicrm.settings.php file you define a CIVICRM_UF_BASEURL which may or may not include the www or https:// on the domain name. For example, it could be: http://yourdomain.org/ https://yourdomain.org/ http://www.yourdomain.org/ https://www.yourdomain.org/ So my ...


4

I'm starting to regret having written this check! So far, I have found four scenarios that result in this false positive: Your php.ini has allow_url_fopen set to false. This should be corrected, since it will subtly break other parts of CiviCRM (e.g. extension download, update checks). Your site is behind a .htpasswd, and thus needs HTTP authentication to ...


4

after chasing my tail for a while, I finally realized that the check for resource url is not done by the browser in a way that would pass along other validation credentials. This led to the resource url check, which tries to load the small arrow image used in the civiCRM admin menus, to fail in my case because all non live/production sites are behind ...


4

Its not a bug, adding extra '/' won't make any difference. The variables shown Directories and Resource URL forms have same naming conventions however they are rendered in different way for each form. CiviCRM Resource URL: [civicrm.root]/ Image Upload URL: [civicrm.files]/persist/contribute/ Your Settings looks fine. Cheers Pradeep


4

If you click the help icon in the help text at the top of the page, it shows you the current values.


3

The alert is incorrect. As long as you are not having any other issues besides the alert, you can tell the alert not to remind you again. In addition (now that I see the issue with Contribution pages - sorry I missed that), make sure you have the base page set under CMS settings in the CiviCRM administration settings. In WP go to settings, Permalinks. ...


3

tl;dr: Uncomment and fill in the define('CIVICRM_CMSDIR', '/path/to/install/root/'); in civicrm.settings.php. I traced through the functions that go toward building the URL for loadins crm.ckeditor.js. It seems there's a problem with the logic of the WordPress cmsRootPath function. I can't tell you what the specific issue you're having that's causing ...


2

You can override the SSL settings in civicrm.settings.php, which will hopefully be enough to get you back in. Add the following lines to civicrm.settings.php: global $civicrm_setting; $civicrm_setting['CiviCRM Preferences']['verifySSL'] = false; $civicrm_setting['CiviCRM Preferences']['enableSSL'] = false; Sources: https://wiki.civicrm.org/confluence/...


2

If I understand your question correctly, you are asking how to return the settings back to default. I believe that the default settings for WordPress (in Administer >> System Settings >> Resource URLs) are as follows: CiviCRM Resource URL: [civicrm.root]/ Image Upload URL: [civicrm.files]/persist/contribute/ Custom CSS URL: (blank) Extension Resource URL: [...


2

The 'Extension Resource URL' under 'Resource URLs' is the web-accessible URL that points to the extensions directory, not the path to that directory on the server's filesystem. The path on the server belongs in 'CiviCRM Extensions Directory' under 'Directories'. Edit: for the example shown, the 'Extension Resource URL' is 'https://ffnew/sites/default/...


2

Starting in 4.7.26 in order to handle the multiple ways that WordPress can be installed on various hosts, we are determining the correct path and setting both the path to the site (front end) and the path to the backend (wp-admin) in civicrm.settings.php. The resource url status warning will need to be updated to handle this.


2

If you have a Security Plugin that filters based on user agent that will block the check and result in a false positive. https://issues.civicrm.org/jira/browse/CRM-21629 If you are using a local site or dev site that isn't connected to a real URL this check will also fail. You can solve this by editting the host file on the machine the site is running on.


2

You can use {crmResURL ext='civicrm.files'}


2

We are seeing this same issue and reported it here https://issues.civicrm.org/jira/browse/CRM-21785?jql=text%20~%20%22resource%20url%22. It appears to be a false positive however.


2

We deduced that this error message comes from the timeout being too small in the public function fileExists($url, $timeout = 0.50) in civicrm-core/CRM/Utils/Check/Component.php. The timeout is not long enough for all sites which is why the message pops up despite the settings being correct. This can be resolved by either hacking the source code and ...


1

I just had this problem on a Drupal installation and found a cause. In my situation, it was a false positive. To check if the resource URL is correctly set CiviCRM tries to download the following picture from the server https://<server>/sites/all/modules/civicrm/packages/jquery/css/images/arrow.png It does the check, however, on the server itself, ...


1

Normally it's [civicrm.root]/. Is that screenshot just an example of values you've been playing with? Does it work with [civicrm.root]/? And [civicrm.root]/ is what it is set to on https://wpmaster.demo.civicrm.org. Also check your civicrm.settings.php file to see if it's overriding it for some reason.


1

This usually happens when your site directory is using symbolic link. To fix the variables you will need to make sure that the docroot specified in apache/ngnix config should match exactly with $civicrm_root and CIVICRM_TEMPLATE_COMPILEDIR in civicrm.settings.php. Try updating if its different and clear CiviCRM cache. Cheers Pradeep


1

I'm the author of this check. My guess is that you're forwarding port 80 on the virtual machine to port 10080 on the host machine. However, the check, since it runs over HTTP internally on the virtual machine, is checking port 80. That SHOULD work properly to detect whether your paths are correct, but I haven't tested this scenario. If you know for a ...


1

Can you make sure in Directories and Resource url settings you are using real-time paths rather hardcoded paths in all text fields on the form. eg [cms.root]uploads/temp/ and not using /home/myusername/mysite.org/wp-content/plugins/civicrm/ Some organisation define this settings in civicrm.settings.php if thats the case in yours than you will need to update ...


1

I fixed it. I opened Administer -> System Settings -> Resource URLs. I then changed CiviCRM Resource URL from [civicrm.root]/ to administrator/components/com_civicrm/civicrm/ I then removed my hack (the symbolic link), refreshed the contribution page and all is well. I also verfied by looking at the source for the contribution page and it show the correct ...


1

Details on the Smarty CiviCRM interface are here: https://docs.civicrm.org/dev/en/master/api/interfaces/#smarty-api-interface However, this seems like overkill for handling the date issue. I suspect that this can be fixed by changing the currency settings (Administer menu » Localizations » Languages, Currency, Location). If this does NOT fix your issue, ...


1

One reason that the value may not change is because it's overridden in civicrm.settings.php. See the Overriding Settings section of the documentation. An upcoming version of CiviCRM will make overridden settings clearly non-editable, but for now, check civicrm.settings.php.


1

This is a bug, related to Status page angular load error. Since your "Image Upload URL" and "Image Directory" are in different places, try disabling Asset Caching at Administer > System Settings > Debugging and Error Handling, at least until this bug is fixed. Please also see civimail - screen for composing a mail is blank


1

CiviCRM can have issues resolving symlinks if they exist in the path to CiviCRM codebase or resources (mentioned also here). Either avoid symlinks in your filesystem layout, or supply CiviCRM with the "real" path for the directory.


1

it seems like my main problem was running the site in dev mode (no page cacheing). I turned on page cache for anon users and also aggregate and compress .js and .css files (/admin/config/development/performance) and my overall site performance has increased dramatically and also seems to have resolved my .css errors. One tool that helped me tremendously ...


1

For a domain change, look at the civicrm.settings.php file the 'CIVICRM_UF_BASEURL' is the field you are looking for. For CiviCRM version 4.7.x this will be in wp-content/uploads/civicrm/ For CiviCRM versions 4.6.x and lower this will be in wp-content/plugins/civicrm/ You may also need to make changes for WP, but this is what you'll need to start with for ...


1

Wrong question was asked; fancy CiviCRM stuff works almost, if properly called via CiviCRM own jQuery methods; pretty strange CRM.alert in Chrome pops up a default JS alert() message though, so it might be better to use CRM.status with appropriate parameters This page helps a lot: https://wiki.civicrm.org/confluence/display/CRMDOC/Notifications+and+...


Only top voted, non community-wiki answers of a minimum length are eligible