Hot answers tagged

14

PHP5.6 has enabled peer verification by default from 5.6.x. The most likely cause of this issue is that the SMTP server's SSL cert does not validate against the certs available to the hosting environment. So, on PHP5.6+, an SMTP connection via SSL and TLS will fail in CiviCRM if the certificates are not peer verified. This is an issue either with the SMTP ...


11

The recommended and least invasive fix is to resolve the underlying SSL issues. It was intentional that PHP5.6 tightened security here. If your hosting environment doesn't validate the SSL certificate you're communicating with, one of these things is probably true - The hosting environment has a misconfigured certificate chain. (Fix varies by hosting ...


7

CiviCRM doesn't require an external mail service, it's possible to deliver mail directly from most web hosts. Quality and limitations may vary on some webhosts, and you may have to contend with other websites in a shared environment affecting your reputation. Running your own mail service on the server/VM you run CiviCRM on is also an option but not for the ...


7

I had to go this far... $this->_socket_options = array('ssl' => array('verify_peer'=>false,'verify_peer_name'=>false,'allow_self_signed'=>true));


6

From what I understand, this can be because the server you contact has a self-signed certificate (see this question for a workaround), or because the PEAR SMTP package version used by CiviCRM does not support TLS. Civi uses 1.6.1, but support was added in 1.7.1. In our case (php7, CiviCRM 4.7), we are able to work around this by forcing SSL connection ...


6

you can send via SMTP, so without any extension. However, you will not handle events about bounces, so civicrm will not be able to update the contact to flag that the email is invalid. So you will keep sending emails to the same invalid email, how mandrill will handle that (eg blacklist these emails, invoicing them as sent... up to ban you) is based on how ...


6

If you are connecting to well known third party mail provider, then it's highly likely that they have their certificates set up properly and you shouldn't need to disable peer verification. Check two things: As it mentions on the Settings - Outbound Mail form, 'if the server uses SSL, add "ssl://" to the beginning of the server name'. Check what port you ...


5

Configuring CiviCRM SMTP for using Google Mail's SMTP services: SMTP Server: ssl://smtp.gmail.com SMTP Port: 465 Authentication: Yes SMTP Username: <your valid Google mail username> SMTP Password: <your valid Google mail password> Finally, you likely need to tell Google that you wish to allow this level of access. See here: ...


5

Welcome in the world of preventing spam. Your email is rejected by a Microsoft service, so Microsoft sets the rules. According to their documentation, the cause may be spoofing or, more likely in your case an incorrectly configured Sender Policy Framework (SPF) record. You can reproduce this problem by sending a single email to an outlook address by using ...


5

I experienced this problem when I was running different versions of PHP in the website and my command line interface (CLI). You can check your PHP version for the web at Administer menu » Administration Console » System Status. You can find your CLI PHP version by running php -v. I was running 7.0 and 7.2 respectively. Since PHP 7.2 has deprecated the ...


4

I've been doing some testing with the last release of the Mandrill Emails Extension and it's looking pretty quick and simple with the new version to do both transactional and bulk mailing (CiviMail) through Mandrill. Basically you install it, plug in your Login/API credentials (Administer > System Settings > Mandrill Smtp Settings), and indicate one or both ...


4

Go to Administer> System Settings> Outbound Email (SMTP/Sendmail) Select SMTP server: smtp.sendgrid.net port: 587 authenticate: Yes Username: your sendgrid username password: your sendgrid password


4

For anyone looking at this now if you are having issues with credentials that you think should not be blocked but are it is probably your firewall.


3

This conversation has been taking place on the CiviCRM Partners' list in the past week. Fortunately, some folks from the list created a wiki page to track the best options, which is available here: Mailing Providers. I like Amazon SES, which termdark referenced (I'm the author of that documentation they linked). However, CiviCRM partners with much larger ...


3

I had exactly the same problem: port 587 doesn't work for me either .. 2525 does


3

First step would be to use Server: imap.gmail.com. smtp.gmail.com is for outgoing mail and Bounce Processing is for checking incoming mail. Second step would be to verify that Less secure app access is enabled in Gmail. If that doesn't solve the problem, here are the settings that work for me with Google Apps for bounce processing, same as what you have but ...


3

What version did you upgrade from? You may have to set up CRED_KEYS in civicrm.settings.php. See https://docs.civicrm.org/sysadmin/en/latest/upgrade/version-specific/#civicrm-534


2

Same error with CiviCRM 4.7.4, Drupal : authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 continue)]. Using mail() allows us to send mails, but with the local SMTP server. Downgrading to PHP5.5 resolves this problem. With PHP5.6 the problem is in packages/Net/SMTP.php when calling $this->_socket->enableCrypto() This is due ...


2

There are a couple of points to this. 1 - SMTP is chatty, it is a fairly slow protocol. To combat this, run several mailing jobs in parallel. This can be achieved by calling the process_mailing cron job multiple more frequently. Ensure that the 'cron job limit' is equal to the maximum number mailing jobs you would want to be active at any one time. This is ...


2

Amazon SES is a suitable replacement for those on a budget. There's some useful documentation on getting it set up with CiviCRM at: https://hq.palantetech.coop/projects/commons/wiki/Amazon_SES_for_CiviCRM I'd advise you to set up the Postix server as SES lacks much of the more useful functionality of Mandrill.


2

This question appears to be the same as Outbound mail fails after upgrading to 4.7.1 tl/dr i suspect your probably running on php5.6 or similar version and the ssl certificate for smtp.mailgun.org is not valid or is a CACert or similar and PHP5.6 is saying i can't validate certificate.


2

It doesn't appear to be an authentication issue, it appears to be a network issue. Do you have a firewall on the server, or between the server and the Internet that could be blocking your outbound request to port 465?


2

Try sending you mailings to the email address on https://www.mail-tester.com and checking the results (just folw the big instructions on the page) - ain't no good if you get a rainy day - you need bright sunshine and birds singin'. MSOutlook servers also often require the DMARC record set (it' tell you how). SPF and DKIM are also good, but check the report....


2

Yes you should fork the repo and create a pull request against the Master branch which i assume is the branch with the issue. Please see this documentation on contributing to CiviCRM https://wiki.civicrm.org/confluence/display/CRMDOC/Contributing+to+CiviCRM+using+GitHub


2

The error in red shows 'Name or service not known' so the problem is related to the server name 'smtp.touchingbase.org'. There is no public DNS record for that. Did you enter the wrong name?


2

See the 'Support for Plus Addressing in Office 365' roadmap item for Exchange Online... due July 2020 "Plus Addressing is a great way to quickly create custom (or disposable) email addresses based off your standard email address, by simply adding a "+" suffix string to an existing email address in Office 365. For example, a plus address for kimakers@contoso....


2

It seems there is a difference between sending via Gsuite and Gsuite SMTP Relay ... For sending via Gsuite, and comparing the connection details in the post you linked to with a site using this, the difference is that it uses SMTP host ssl://smtp.gmail.com The main practical limitations are the limits and that all mails get sent out with the sender of the ...


2

Its been a while - but hope these tips help: Make sure you greenlight the IP address of your server for smtp relay. Sometimes your webhost will block outgoing smtp ports to servers other than their own. Ask your host to remove this limitation, if they do not, find another host. This is common with shared hosting. There are issues with Gsuite smtp relat long ...


2

The solution is here.Generate a sixteen-digit token and use the token instead of your Gmail password. So the SMTP settings will be: SMTP server - smtp.gmail.com SMTP port - 587 Authentication - Yes SMTP username - Gmail account username SMTP password - 16-digit token (not your Gmail password)


1

Hello all and thank you for the responses! Ultimately we figured out that our SMTP server was, indeed, not correct. We found the correct one by going into our Outlook email application and copying the correct SMTP server from there. SUCCESS! Thanks again!


Only top voted, non community-wiki answers of a minimum length are eligible