Hot answers tagged

6

Yes - I'm using it on one production site and one pre-production. One has the full letsencrypt client, but it assumes root access. The other uses an alternative client https://github.com/diafygi/letsencrypt-nosudo that doesn't need root and works on shared hosting (but you may need to tweak your .htaccess file for the verification process). I've not ...


4

Verify the file which is being reported as having a syntax error. PHP has a syntax check mode with -l (for "lint"). php.exe -l C:\vhost\sdbikecoalition\wp-content\uploads\civicrm\civicrm.settings.php If civicrm.settings.php is not valid PHP, CiviCRM will not function - SSL or no SSL. Note that your local PHP install may differ in version and therefore ...


4

I think that error message is coming from your civicrm install attempting to check for extension updates. It does this as part of its routine status checks. There is a fixme in the code to handle failures like this more gracefully - it really should be logging the error and not bugging you about it.


4

I am using a hosting control panel that supports it. Sign up, certificate creation and renewal are hassle free with this panel. You only need a (virtual private) server, and a linux distribution, preferably Debian for better support. According to their comparison chart, Let's encrypt is supported both in Standard and Business edition. The panel is written ...


3

Check your civicrm.settings.php and check also the settings under adminster --> system settings --> resource urls In the latter you can force civicrm to load css/js via https


3

Check that you have set "Verify SSL" to "No" at civicrm/admin/setting/url Note that CiviCRM is storing absolute URLs in DB civicrm_contact.image_URL - even once your SSL config is fine, you may see images not appear on SSL due to CRM-14207: Contact's image URL is full & absolute path


3

Our WordPress 4.6.1 + CiviCRM 4.7.12 instance is hosted on Dreamhost. I simply added a free Let's Encrypt SSL certificate to our site from the Dreamhost cpanel, installed the "Really Simple SSL" WordPress plugin, activated, and done. Without the plugin, I was getting mixed-content warnings. Afterwards, in Chrome, the green lock displays in the address bar ...


2

One possibility is that you are trying to send an email with a "From address" that is not in the sending domain(s) that you have verified in SparkPost. I think they only allow email from verified domains, so you can't send "from" a Gmail address in CiviCRM, for example. If you are having trouble with the PESC Sparkpost extension you may want to try the one ...


2

There is nothing specific about civi on your question, it is possible to use a wildchar certificate (*.site.com) or one that works for several subdomains. If you want a simple and free certificate and that isn't offered by your hosting company, I recommend you "let's encrypt".


2

You don't say what CiviCRM version you have but this was fixed in 5.27.0 https://lab.civicrm.org/dev/core/-/issues/1608 & sounds similar This patch - https://github.com/civicrm/civicrm-core/pull/18062 should improve the quality of your error logging


2

You don't actually have to replace mysql with mysqli since core already has a "hack" that will do this for you if the php mysqli extension is loaded. https://github.com/civicrm/civicrm-packages/blob/5.15.1/DB.php#L747 For the ssl, it seems reasonable to propose an update to that same function that lets you set the ssl option, either as part of CIVICRM_DSN ...


1

I managed to get this working. I did a clean install of everything, Followed the wordpress civicrm install instructions for clean URLS Enforced SSL using the siteground hosting built in tools Enforced SSL in civicrm Then in the wordpress permalinks settings removed any reference to index.php. Not totally sure whether this combination of things was ...


1

Three things to try, in this order: Administer menu » System Settings » Resource URLs. Ensure "Force Secure URLs" is set to "No". Clear cache and templates_c. Rebuild the menu: http://<wordpress_site>/wp-admin/admin.php?page=CiviCRM&q=civicrm/menu/rebuild&reset=1


1

Turns out the issue was our server's operating system. We were on CentOS 5.5, and it doesn't support OpenSSL higher than 0.9.8. We had to upgrade to a new server. We decided on a CentOS 7 server and are in the process of migrating. The CentOS 7 server came with OpenSSL 1.0.2 installed. I setup and tested our connection with iATS today and had it working in ...


1

This problem has been assigned to a CiviCRM bug which requires funding to resolve. The suggested fix is an AJAx solution. See: https://issues.civicrm.org/jira/browse/CRM-17663


Only top voted, non community-wiki answers of a minimum length are eligible