6

The warning is because the timezone of the server does not match with the timezone set in MySQL. We had similar warning and after setting the timezone in both Centos & MySQL, the warning is not displayed anymore. Additional Info: This is how we corrected/fixed the timezones, if it helps. The below instructions are for setting timezone to GMT, you need to ...


3

I don't think that this is currently possible. The time part will we stripped in CRM_Utils_Date::convertToDefaultDate() called here: https://github.com/civicrm/civicrm-core/blob/master/CRM/Contact/Import/Parser/Contact.php#L1909 You could have an extension read an imported text field with a date string and set the proper datetime value for the custom field ...


3

Try setting your preferred timezone in civicrm.settings.php and/or wp-config.php? ini_set('date.timezone', 'Asia/Calcutta'); You might want to adapt the timezone you set as appropriate to your MySQL server. mysql -e 'SELECT @@system_time_zone;' I believe India does not observe daylight savings? For that and similar reasons it's probably better to match ...


3

In my experience with this, you can modify the default timezone setting for your CMS. Not sure how to do this in Joomla, but there are UI options for this in both Wordpress and Drupal so I would imagine that Joomla offers a similar setting.


2

An issue has been created for a similar requirement: CRM-17618 - time zone field needed for event creation. You could check whether the requirements described there cover your use case and see if there's scope for collaboration, joint funding etc.


2

No existing fix I know of. It's maddening, and the prime example of this is civicrm.org! The site runs in US Pacific time, so when we have Washington, DC, meetups scheduled, the iCal has the wrong time.


2

I followed the instructions on Word Press Install Missing civicrm.settings.php; dashboard unavailable; no menus and was able to add the following immediately after the initial <?php line of my wp-content/uploads/civicrm/civicrm.settings.php file: global $civicrm_setting; $civicrm_setting['Directory Preferences']['customTemplateDir'] = 'public_html/wp-...


1

[UPDATE - IS FIXED] I fixed this by revisiting WordPress's settings and changing the Timezone setting from "UTC -5" to "Chicago". Both of these settings reflect the same time zone, so why these two settings are seen as different I can't say, but Civi no longer complains. So I guess the lesson is: if you want to get rid of this error and you're showing ...


1

The first thing I would check is the TimeZone setting in WP. Go to Settings--> General. That cannot be the default (UTC +0) as the default does not exist in php (UTC does, but not UTC +0). That should solve the TZ mismatch. Best to use one of these - http://php.net/manual/en/timezones.america.php for NY I'd use America/New_York As far as cron, I ...


Only top voted, non community-wiki answers of a minimum length are eligible