New answers tagged

0

There is a surprisingly simple solution: Smarty assumes, that comparison containing a constant string is unsafe. A remedy is, to assign the constant value to a variable, and to perform the comparison between these two variables. The code example from above could look like: {capture assign=gift}{contact.custom_16}{/capture} {capture assign=Yes}Yes{/capture} {...


0

Just adding an answer - which is actually from the comments - since I think stackexchange doesn't like answers in the comments - anyway - the issue was an extra copy of the codebase


0

This is an issue documented here: https://lab.civicrm.org/dev/core/-/issues/1997 Fixes have been merged into 5.30 branch https://github.com/civicrm/civicrm-core/pull/18525 and https://github.com/civicrm/civicrm-core/pull/18534 So you can apply the patches, or wait until the 5.30 release in early October.


0

Try this extension from bgm: https://civicrm.org/extensions/shoreditch-wordpress-workarounds It's working better than the CiviCRM Admin Utilities WP-Plugin.


0

Do you have Shoreditch theme installed? This will complicate a few things in WordPress and even the fabulous CiviCRM Admin Utilities WP-Plugin won't fix it. Try this extension from bgm: https://civicrm.org/extensions/shoreditch-wordpress-workarounds


3

This was caused by an issue with my local disk cache. Clearing the cache from my browser allowed the icons to be displayed again.


0

There are a bunch of icon changes in civi over a couple releases and shoreditch might not be up to date with all of them. There were similar reports for "more" dropdown icons. You could try the latest master version of shoreditch.


1

Uninstalling and reinstalling the extension fixed an issue with a report template, causing the error.


0

DNS changes can take up to 48 hours to propagate, and the time can vary widely for each computer trying accessing your site due to the many stages of caching involved. Your payment processor might not have received the new DNS records yet, so wait a day or two. Most/all will retry each payment notification for a number of days/weeks, so you will not lose any ...


0

I would guess that anonymous users are not able to view and use contribution pages. Confirm and change this at: Administer->Users and Permissions->Permissions (Access Control)->Wordpress Access Control. OR https://yoursite.tld/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Faccess%2Fwp-permissions&reset=1


1

In the end, I was not able to find the solution. I "solved" it by setting up a new site and migrating the CiviCRM data to that.


4

Add the following to your wp-config.php file: define( 'CIVICRM_WP_PROFILE_SYNC_BULK', true ); Then select some contacts and use the “Actions” dropdown to “Create WordPress Users from Contacts”.


1

check you wordpress directory path in your apache/nginx conf. If its different than '/usr/home/xxxuser/public_html/' either you can change in apache/nginx conf or replace $civicrm_root and template_c path in civicrm.settings.php Or add below line at the end of the file in civicrm.settings.php global $civicrm_paths; $civicrm_paths['civicrm.root']['url'...


0

This all related to the session key issue. Have been able to get over the session key error by installing a fresh install of WP and CiviCRM, then restoring Wordpress and CiviCRM DBs, repointing wp_config.php and CiviCRM.settings.php. Also had to rename my table prefixes in wp_config.php to match my restored tables. The caches get created once you start up ...


0

Have been able to get over the session key error by installing a fresh install of WP and CiviCRM, then restoring Wordpress and CiviCRM DBs, repointing wp_config.php and CiviCRM.settings.php. Also had to rename my table prefixes in wp_config.php to match my restored tables. The caches get created once you start up CiviCRM and do things. Testing so far all ...


3

This is down to the fact that you probably have logging turned on in your Drupal environment. So the easiest thing to do would be to turn it off before you migrate and turn it back on in Wordpress (Administer -> Misc -> Logging). If you cant do that (or it still doesn't work) then you have a couple of 'hacks' to make get to the point that you can at ...


0

Kevin's suggestion to look at the browser console is a good suggestion - you do this by pressing "F12" on your keyboard and selecting the "Console" tab. Also check the "Network" tab for errors (you'll need to reload the page after selecting the tab). Updating the question with info you find there will help people troubleshoot. ...


0

Turns out the problem is related to the latest install of the UK Gift Aid extension v 3.4.4. Disabling the extension brings back the menus.


1

I was under the assumption that you do not require CiviCRM WP REST API plugin anymore if you are on 5.28.x To ignore the Site Health error you install a small plugin that i have created.


0

I'd start by clearing CiviCRM Cache https://yoururl.org/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Fsetting%2FupdateConfigBackend&reset=1 I'd also refresh permalinks by visiting https://yoururl.org//wp-admin/options-permalink.php Then double check that you have abase page set here and it is publicly visible https://yoursiteurl.org/wp-admin/...


0

Since this is a WordPress specific question I believe these sorts of forms can be built using the Caldera forms integration for CiviCRM.


4

Don't panic, the issue you are seeing is only a notice, not an error and won't stop CiviCRM working. In WordPress 5.5, a change was made to how REST routes are registered and now required a permission_callback. For the moment, the plugin will continue to work and once the plugin author releases an update that adds the permission_callback, the notice will ...


1

Is CiviCRM already installed? Even if the DB is clean, does the wp-content/uploads/civicrm folder exist with the civicrm.settings.php file in it. The installer does not expect that to be there. You shouldn't hit the install page on an upgrade. I'd expect you to go to http://example.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/upgrade&reset=1 Full ...


2

Alex, Welcome to Civi stackexchange. If the server is running with global transaction identifiers (GTIDs) enabled (gtid_mode=ON), do not enable binary logging. Try turning it off


Top 50 recent answers are included