2

The triggers weren't enabled and I tried to get them enabled. Couldn't seem to. Tried uninstalling and reinstalling still didn't work. Dug into it and found it was getting an error when trying to copy the summary fields data from the temp table into the custom fields table. The error was violating a constraint. Debugged it a bit and found that it was creating a row with a null contact_id. Dug into that and found that sumfields.php was doing an outer join incorrectly. I figured that couldn't be current code and looked at the latest and greatest and found that sumfields.php file was different from ours. Sadly, there are no version numbers or anything on that file so it's hard to tell what version it is.

The info files says it's version 3.1.3. I guessing the last upgrade somehow messed this up.

So the question is what's the best way to get current. Is it to just replace all the files in the custom_ext with the current ones or is it to uninstall and delete those files or maybe change the info so it thinks it older so I'll prompt for upgrade.

1

I ended up just changing the version number in the info file to 3.1.0. Then on the Manage Extensions page it then said there was an upgrade. Hit upgrade and everything was good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.