After upgrading to CiviCRM 5.17.4 under Joomla the cron jobs that had worked happily before stopped. They didn't seem to be giving any error, but CiviCRM reported that they had failed to run. We using Cpanel and have the following command line:

php <path>/administrator/components/com_civicrm/civicrm/bin/cli.php -s https://<url>-u <user> -p <password> -e Job -a execute

Any suggestions. We have tried running cron.php, but that, in its current form, doesn't handle parameters when run from the command line.

Has anyone else seen the issue?

1 Answer 1


After much trial and error, this command line seems to work in the Cpanel cron environment:

wget -q -t 1 'https:///administrator/components/com_civicrm/civicrm/bin/cron.php?name=&pass=&key='

instead of php trying to run cron.php.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.