2

I'm finding that when I first go to a CiviCRM page in the morning there's a loading time of just over 1 minute(!)

There are no errors (on screen, nor in apache error log, nor in Drupal's watchdog) and after this delay everything works as normal.

Looking in firebug it's the actual page load that's stuck on client "waiting" for a full minute before it jumps to life and starts loading the zillion other requests typically needed on a CiviCRM page, which all go fast enough.

I've tried to trigger this. Clearing Drupal caches (drush cc all) does not trigger it; clearing CiviCRM caches (via civicrm/admin/setting/updateConfigBackend) do not trigger this delay.

However, adding a new user in Drupal does also trigger it. (Adding a new Contact in CiviCRM does not trigger it.)

Any ideas?

4

This problem is not to do with CiviCRM.

My server defaults to using ipv6 but this is not configured. Therefore when CiviCRM tries a file_get_contents('http...') it is timing out. This vexed me for a while because on the command line wget works fine; I thought I had disabled ipv6 on the server, but turns out file_get_contents doesn't know about that.

Sorry for the non-question! I only saw this happening with CiviCRM. FYI it is triggered by the occasional CiviCRM security checks (which ironically, I recently asked another question about). I don't know when these are triggered; but they are triggered about once a day per user and again if a Drupal user is added.

EDIT

This is not an IPv6 issue, as I originally thought. I now believe it's a problem/quirk of using apache2-mpm-itk as with this worker I get the problem but with the default worker I do not.

I can confirm that this is/was a bug in the Apache MPM ITK module.

For Debian Jessie users, you can get a fix by:

deb http://mirrors.linode.com/debian/ jessie-proposed-updates main

into /etc/apt/sources.list, and then running

apt update && apt install libapache2-mpm-itk
systemctl restart apache2.service

Apparently this fix will make it into Jessie 8.2, too.

| improve this answer | |
0

I have exactly the same issue but I'm running Ubuntu. Can you be more specific about the patch to help me find it for Ubuntu? Thanks!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.