1

I am trying to setup buildkit in my new Debian machine. I installed all the required packaged, ran civi-download-tools and amp config with correct credentials and included Include /root/.amp/apache.d/*.con in apache2.conf file. On restarting apache it gave me error saying there was no *.conf file to be included in /root/.amp/apache.d. I checked the directory; it was empty.

However, I copied localhost-7979.conf from my previous buildkit setup on another machine and placed inside /root/.amp/apache.d folder and restarted apache. On running amp test it gave me following error:

PHP Warning:  file_get_contents(http://localhost:7979/index.php): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden  in phar:///opt/buildkit/bin/amp/src/Amp/Command/TestCommand.php on line 163

I checked localhost-7979-error.log inside root/.amp/log. Following line was there.

'/root/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/root/' is executable'

Strange. There isn't even any .htaccess file inside /root. I tried every solution I could find on CiviCRM StackExchange and Forums but none worked.

1

I was performing all actions as a root. That was probably the reason no .conf file was generated in /root/.amp/apache.d/. I switched to a non-root user with sudo privileges and it worked smoothly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.