2

CiviCRM 4.6.7

I get an error with this command: wget -O - -q -t 1 'http://www.website.org/wp-content/plugins/civicrm/civicrm/bin/cron.php?name=user&pass=password&key=site-key'

Fatal error: Uncaught exception 'Exception' with message 'Function "is_admin()" is missing, even though WordPress is the user framework.' in /var/www/vhosts/website.org/httpdocs/wp-content/plugins/civicrm/civicrm/CRM/Utils/System/Base.php:258

Thanks for helping.

Edit:

With CLI PHP I get this error:

This what I get with CLI PHP:

Sorry. A non-recoverable error has occurred. Could not find the install directory for WordPress

#0 /var/www/vhosts/website.org/httpdocs/wp-content/plugins/civicrm/civicrm/CRM/Utils/System/WordPress.php(343): CRM_Core_Error::fatal("Could not find the install directory for WordPress")
#1 /var/www/vhosts/website.org/httpdocs/wp-content/plugins/civicrm/civicrm/CRM/Utils/System.php(1500): CRM_Utils_System_WordPress->loadBootStrap((Array:0), FALSE, FALSE, "/var/www/vhosts/website.org/httpdocs/wp-content/plugins/civicrm/civicrm/")
#2 /var/www/vhosts/website.org/httpdocs/wp-content/plugins/civicrm/civicrm/bin/cli.class.php(251): CRM_Utils_System::loadBootStrap((Array:0), FALSE, FALSE, "/var/www/vhosts/website.org/httpdocs/wp-content/plugins/civicrm/civicrm/")
#3 /var/www/vhosts/website.org/httpdocs/wp-content/plugins/civicrm/civicrm/bin/cli.class.php(72): civicrm_cli->_bootstrap()
#4 /var/www/vhosts/website.org/httpdocs/wp-content/plugins/civicrm/civicrm/bin/cli.php(31): civicrm_cli->initialize()
#5 {main}
  • Did you try using CLI PHP? – Hershel May 3 '16 at 16:44
  • I am having this same issue. I have used the provided code to define the Wordpress install directory, but I am still unable to run the Cron. Any help would be appreciated. – user2258848 Oct 9 '18 at 20:15
1

I have resolved the issue. The path to the wordpress directory was wrong, don't know why. I have changed hosting during the week.

I had to add this line in civicrm.settings.php:

define('CIVICRM_CMSDIR','/var/www/vhosts/website.org/httpdocs');

This issue helped me: Problem with open_basedir restriction in effect

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.