0

I'm updating an old D6/Civi site to D7. It includes some Drupal Views that display listings of contacts along with the contact image (in our case we're working with organisational contact records and using the contact image field to store a logo.

This just worked on the D6 site, where Views simply provided the raw image URL in [image_URL] and I was able to rewrite it in the View and so control the size of the rendered image to suit the view.

In D7 now this looks totally broken. I can get the view to display the image, but [image_URL] now includes the img tag and everything, so I can't just get the raw URL any more and rewrite it.

There appear to be other questions here referring to the same issue, and a number of issues in Jira, but i can't find anything that provides a decent workable solution.

Has anyone got this resolved, and if so, how?

  • hmm. pretty sure i spelt out what needs putting in the views link. if i spot a site we have this i will post back. – petednz - fuzion Aug 23 '17 at 19:53
1

Did you try the Output the image URL only option as shown below?

Output the image URL only

  • That looks ideal, but I don't see the "output the image URL only" option in my site. I'll check to ensure that everything is up to date. – Graham Aug 24 '17 at 9:51
  • I'm running Civi 4.6.30 at the moment. I'm guessing this feature isn't available in 4.6.x? I will be updating to 4.7 after we've completed the current work programme on the site, so it is at least useful to know that a fix is waiting. – Graham Aug 24 '17 at 9:54
  • 1
    I tested it on 4.7. I suppose it was added with issues.civicrm.org/jira/browse/CRM-17638 .So maybe you can apply this patch on 4.6. – Kainuk - CiviCooP Aug 24 '17 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.