1

We just launched a new Drupal website and implemented our old CiviCRM database. Everything seems to be going fine and transactions are going through, but when we try to view one, as admin or any other user, we get a network error.

Network Error Unable to reach the server. Please refresh this page in your browser and try again.

Admin user has all permissions and is still having the issue.

CiviCRM 4.7.15, Drupal 7.x

Edit: apparently I can't go back and edit payment processors either.

Edit2: apparently it works with the old, pre-launch URL. I ran 'drush cc civicrm' to no avail. I also updated file paths and cleared caches in CRM.

It's possibly related to an issue where some transactions are coming in incomplete.

enter image description here enter image description here

Drupal error log is showing this possibly related message:

Sep 19 16:27:28 prod drupal: https://prod.fosterclub.com|1505838448||access denied||68.116.xx.xx|https://prod.fosterclub.com/civicrm/contact/view/contribution?reset=1&id=5816&cid=121483&action=view&context=dashboard&selectedChild=contribute&snippet=json|https://www.fosterclub.com/civicrm/contribute?reset=1|0||civicrm/contact/view/contribution

Furthermore, when I hover over the link to view the transactions, it is showing prod.example.com instead of www.example.com, which was the correct URL before the DNS change and launch.

  • can you paste the screenshot and the errors you see on browser console? – jitendra - fuzion Sep 19 '17 at 2:40
2

If it's showing the wrong URL, you should:

  • Confirm your $BASE_URL is correct in civicrm.settings.php;
  • Check your URLs in Administer menu » System Settings » Resource URLs;
  • Clear your cache;
  • Delete templates_c.
  • 1
    As a general troubleshooting tip, any time you get an error on a modal ("pop-up") dialog, right-click the link and select "Open in New Tab", you'll get much more detailed errors. – Jon G - Megaphone Tech Sep 19 '17 at 16:41
  • I posted my answer before I saw this. Thank you. The last three I had done but it was the first one that I missed. – Christia Sep 19 '17 at 16:41
0

I forgot to update the URL in civicrm.settings.php from prod. to www.

That's all it was.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.