I'm trying to install the buildkit tools on a Ubuntu based virtual machine install of a LAMP pre-made vm.
I've tried as root (bad form) and I tried as www-data, which is the same user as apache and has sudo privileges. I don't understand what is blocking me here - why am I getting this error?

> npm WARN deprecated bower@1.8.2: ...psst! Your project can stop
> working at any moment because its dependencies can change. Prevent
> this by migrating to Yarn:
> https://bower.io/blog/2017/how-to-migrate-away-from-bower/ npm WARN
> engine protractor@4.0.14: wanted: {"node":">=4.2.x"} (current:
> {"node":"0.10.29","npm":"1.4.21"}) npm WARN deprecated
> graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility
> with current and future versions of Node.js npm WARN deprecated
> minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid
> a RegExp DoS issue npm WARN deprecated connect@2.30.2: connect 2.x
> series is deprecated npm WARN engine node-version@1.1.0: wanted:
> {"node":">=4.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"}) npm
> WARN engine mime@1.6.0: wanted: {"node":">=4"} (current:
> {"node":"0.10.29","npm":"1.4.21"}) npm WARN optional dep failed,
> continuing fsevents@1.1.3 npm WARN engine request@2.83.0: wanted:
> {"node":">= 4"} (current: {"node":"0.10.29","npm":"1.4.21"}) npm ERR!
> 404 Not Found npm ERR! 404  npm ERR! 404 'types/selenium-webdriver' is
> not in the npm registry. npm ERR! 404 You should bug the author to
> publish it npm ERR! 404 It was specified as a dependency of
> 'protractor' npm ERR! 404  npm ERR! 404 Note that you can also install
> from a npm ERR! 404 tarball, folder, or http url, or git url.
> npm ERR! System Linux 3.16.0-5-amd64 npm ERR! command
> "/usr/bin/nodejs" "/usr/bin/npm" "install" npm ERR! cwd
> /var/www/buildkit npm ERR! node -v v0.10.29 npm ERR! npm -v 1.4.21 npm
> ERR! code E404 npm WARN engine har-validator@5.0.3: wanted:
> {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"}) npm WARN
> engine hawk@6.0.2: wanted: {"node":">=4.5.0"} (current:
> {"node":"0.10.29","npm":"1.4.21"}) npm WARN engine form-data@2.3.2:
> wanted: {"node":">= 0.12"} (current:
> {"node":"0.10.29","npm":"1.4.21"}) npm WARN engine har-schema@2.0.0:
> wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
> npm WARN engine sntp@2.1.0: wanted: {"node":">=4.0.0"} (current:
> {"node":"0.10.29","npm":"1.4.21"}) npm WARN engine hoek@4.2.1: wanted:
> {"node":">=4.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"}) npm
> WARN engine cryptiles@3.1.2: wanted: {"node":">=4.0.0"} (current:
> {"node":"0.10.29","npm":"1.4.21"}) npm WARN engine boom@4.3.1: wanted:
> {"node":">=4.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"}) npm
> WARN engine boom@5.2.0: wanted: {"node":">=4.0.0"} (current:
> {"node":"0.10.29","npm":"1.4.21"}) npm WARN engine co@4.6.0: wanted:
> {"iojs":">= 1.0.0","node":">= 0.12.0"} (current:
> {"node":"0.10.29","npm":"1.4.21"})
> > phantomjs-prebuilt@2.1.16 install /var/www/buildkit/node_modules/karma-phantomjs-launcher/node_modules/phantomjs-prebuilt
> > node install.js
> /var/www/buildkit/node_modules/karma-phantomjs-launcher/node_modules/phantomjs-prebuilt/node_modules/request/node_modules/hawk/node_modules/boom/lib/index.js:5
> const Hoek = require('hoek'); ^^^^^ SyntaxError: Use of const in
> strict mode.
>     at Module._compile (module.js:439:25)
>     at Object.Module._extensions..js (module.js:474:10)
>     at Module.load (module.js:356:32)
>     at Function.Module._load (module.js:312:12)
>     at Module.require (module.js:364:17)
>     at require (module.js:380:17)
>     at Object.<anonymous> (/var/www/buildkit/node_modules/karma-phantomjs-launcher/node_modules/phantomjs-prebuilt/node_modules/request/node_modules/hawk/lib/index.js:5:33)
>     at Module._compile (module.js:456:26)
>     at Object.Module._extensions..js (module.js:474:10)
>     at Module.load (module.js:356:32) npm WARN This failure might be due to the use of legacy binary "node" npm WARN For further
> explanations, please read /usr/share/doc/nodejs/README.Debian   npm
> ERR! Error: ENOENT, lstat
> '/var/www/buildkit/node_modules/karma-phantomjs-launcher/node_modules/lodash/unionBy.js'
> npm ERR! If you need help, you may report this *entire* log, npm ERR!
> including the npm and node versions, at: npm ERR!    
> <http://github.com/npm/npm/issues>
> npm ERR! System Linux 3.16.0-5-amd64 npm ERR! command
> "/usr/bin/nodejs" "/usr/bin/npm" "install" npm ERR! cwd
> /var/www/buildkit npm ERR! node -v v0.10.29 npm ERR! npm -v 1.4.21 npm
> ERR! path
> /var/www/buildkit/node_modules/karma-phantomjs-launcher/node_modules/lodash/unionBy.js
> npm ERR! fstream_path
> /var/www/buildkit/node_modules/karma-phantomjs-launcher/node_modules/lodash/unionBy.js
> npm ERR! fstream_type File npm ERR! fstream_class FileWriter npm ERR!
> code ENOENT npm ERR! errno 34 npm ERR! fstream_stack
> /usr/lib/nodejs/fstream/lib/writer.js:284:26 npm ERR! fstream_stack
> Object.oncomplete (evalmachine.<anonymous>:107:15)
> > ws@0.4.32 install /var/www/buildkit/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws
> > (node-gyp rebuild 2> builderror.log) || (exit 0)
> make: Entering directory
> '/var/www/buildkit/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws/build'
> CXX(target) Release/obj.target/bufferutil/src/bufferutil.o  
> SOLINK_MODULE(target) Release/obj.target/bufferutil.node  
> SOLINK_MODULE(target) Release/obj.target/bufferutil.node: Finished  
> COPY Release/bufferutil.node   CXX(target)
> Release/obj.target/validation/src/validation.o   SOLINK_MODULE(target)
> Release/obj.target/validation.node   SOLINK_MODULE(target)
> Release/obj.target/validation.node: Finished   COPY
> Release/validation.node make: Leaving directory
> '/var/www/buildkit/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws/build'
> npm ERR!  npm ERR! Additional logging details can be found in: npm
> ERR!     /var/www/buildkit/npm-debug.log npm ERR! not ok code 0

1 Answer 1


Issue was resolved by installing nodejs from nodejs.org. The Ubuntu version doesn't working with the buildkit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.