Following the steps in https://docs.civicrm.org/sysadmin/en/latest/setup/oauth/

After the installation of the OAuth2 extension, I don't get an "OAuth" item in the menu "Administer => System Settings => OAuth" There is an "Authentication" item, but it points to authx, not to OAuth.

So, I am not getting the CiviCRM page where I can paste the "Client ID" and "Client Secret" values into the client.

How to continue? Can I get the page using cv?

-- CiviCRM 5.59.3 on DRUPAL

  • have you tried rebuilding your menus?
    – kapn
    Commented Apr 13, 2023 at 17:31
  • @kapn, yes, i always do
    – MarkDQ
    Commented Apr 18, 2023 at 16:46
  • Not sure what to suggest. I've not run into things not appearing on menus even after a rebuild. I would personally try uninstalling and re-installing the extension, but maybe you've tried that too.
    – kapn
    Commented Apr 19, 2023 at 19:50
  • @kapn yes i tried un-/re-installing too.
    – MarkDQ
    Commented Apr 21, 2023 at 9:48
  • @kapn do you know the link that is called up in the menu item?
    – MarkDQ
    Commented Apr 21, 2023 at 9:51

1 Answer 1


For backdrop the url is : website.com/civicrm/admin/oauth

I had the same issue, no Oauth menu, but we have a staging version of the site which is showing the Oauth menu item -- so I used that to get a working url (above).

But I got an access denied error. I asked my co-worker to log in and see if that's what they got too -- which is what they got it; they then reminded me that the permissions are not set for roles/users for Oauth -- so I set the permissions and that seemed to have worked: website.com/admin/config/people/permissions

Again this is for backdrop. Hope this helps.

  • Agree that if a menu item is missing for something that has been recently added/enabled (or just used/noticed for the first time) then go check the CMS permissions
    – petednz - fuzion
    Commented May 19, 2023 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.