1

I have activated the CiviRules extension and created a workflow. It says it saved however the screen is empty when I go to Manage CiviRules. No filters selected it's just a general search. I checked both enabled and disabled but the list is blank. Does anyone know how this might be able to be fixed?

enter image description here

UPDATE: I did confirm the rules are showing in the database.

enter image description here

UPDATE 2: There are javascript errors on the page but they do not seem relevant?

enter image description here

7
  • Does the civirule_rule table have any entries? (ie is the problem that it didn't save, or won't display)
    – Aidan
    Feb 14 at 17:51
  • @Aidan I have added a screenshot showing the data is in the database
    – Mary
    Feb 15 at 2:06
  • Is there a javascript error in the browser console?
    – Demerit
    Feb 15 at 2:42
  • @Demerit I updated with a screenshot with the only 2 errors I see but I don't think they would matter in this case. please let me know if I am wrong.
    – Mary
    Feb 15 at 13:52
  • Right that doesn't seem important. How about if you go into searchkit and on the packaged searches tab, and look at the searchkit for Civirules - does it maybe look like it's been corrupted or someone's edited it?
    – Demerit
    Feb 15 at 14:53

1 Answer 1

2

Ug stupid me didn't try the classic 'turn it off and on again approach'. I tried your searchkit idea @Demerit but that didn't work. So I instead disabled, uninstalled, and reinstalled, and now showing saved rules.

Thank you everyone for your support!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.