Following an earlier question about a missing field in Views 3 I opted to go down the route of creating a completely custom report.

With this done and working correctly, I attempted to place it on the CiviCRM dashboard to be presented with a Not Found error (from my apache server). Expanding the dashlet opens the report correctly, oddly.

All dashlets are displaying a Not Found error. As this is the first time we have actively used this I cannot be certain if this ever worked, though I remember the default CiviCRM News dashlet having the same issue after the upgrade several months ago.

Is there anything anyone can suggest to get the dashlets working correctly? Thanks

1 Answer 1


Not sure if this is solved, but we had the same issue running on a Debian server and the host was resolving the DNS name to the legacy site (we were testing). So to resolve the 404 errors on the dashlets, we had to enter a host entry in /etc/hosts to point the DNS name to the local IP address (instead of it resolving on the net to the existing legacy server IP).

If on windows, you'll need to do this in C:\Windows\System32\drivers\etc\hosts

  • Can't believe it was that simple... thx Commented Oct 15, 2016 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.