4

I am asking this question to clarify the issue raised in this question: Available countries list won't appear when set in Localization

The user interface on the 'Settings - Localization' page (admin/setting/localization) has changed in CiviCRM 4.7. As a result there doesn't seem to be an easy way to select all countries to be available for address fields.

In CiviCRM 4.6 and before you could simply select the whole list of countries and click 'Add' to make them all available. However in CiviCRM 4.7 you appear to have to add each country individually, which is a time-consuming task as there are a large number of countries.

This appears to be a step backwards in terms of the user experience. Is this a bug or am I missing something?

Also the help text for this fields needs updating. It currently reads as follows:

Available Countries

Which countries are available in the Country selection field when adding or editing contact addresses. Profile and Custom 'Country' fields also use this setting. To include ALL countries, leave the right-hand box empty.

In CiviCRM 4.7 there is only one box. There is no right-hand box. If you leave the box blank and click save it will revert to the default country (i.e. 'United States').

1

While a better user interface would be preferable, there IS a pretty decent solution for technical users suggested here: https://civicrm.stackexchange.com/a/10013/12

  • Does this mean that this is a bug in CiviCRM 4.7? – William Mortada Mar 3 '16 at 9:04
  • Having encountered this too, I would say it is a bug – Christian Wach Mar 3 '16 at 11:34
0

Yes: There is option to enable other countries.

Go the Administer->Localisation->Languages, Currency, Location.

Now select countries and add them. Now you will see this countries in Registration page.

  • Thanks for your post but this doesn't really answer the question. I was asking how to add ALL countries in one go. – William Mortada Feb 16 '18 at 9:17
  • 1
    Select first country and by pressing shift select last country by scroll. And then Click on Add button. – vijay Feb 16 '18 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.