3

The error message I am receiving is:

Sorry but we are not able to provide this at the moment. One of parameters (value: ) is not of the type Integer

I have tested this on a clean install of CiviCRM 4.6.18 with only CiviRules installed and still get this error. It occurs on any Event Trigger (create,change,delete).

and spits out this backtrace error:

#0 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Core/Error.php(360): CRM_Core_Error::backtrace()
#1 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Utils/Type.php(415): CRM_Core_Error::fatal("One of parameters  (value: ) is not of the type Integer")
#2 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Core/DAO.php(1251): CRM_Utils_Type::validate(NULL, "Integer")
#3 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Core/DAO.php(1168): CRM_Core_DAO::composeQuery("INSERT INTO `civirule_rule_log` (`rule_id`, `contact_id`, `log_date`) VALUES ...", (Array:2), TRUE)
#4 /var/www/clients/client1/web8/web/sites/default/files/civicrm/ext/org.civicoop.civirules/org.civicoop.civirules-master/CRM/Civirules/Engine.php(285): CRM_Core_DAO::executeQuery("INSERT INTO `civirule_rule_log` (`rule_id`, `contact_id`, `log_date`) VALUES ...", (Array:2))
#5 /var/www/clients/client1/web8/web/sites/default/files/civicrm/ext/org.civicoop.civirules/org.civicoop.civirules-master/CRM/Civirules/Engine.php(30): CRM_Civirules_Engine::logRule(Object(CRM_Civirules_TriggerData_Post))
#6 /var/www/clients/client1/web8/web/sites/default/files/civicrm/ext/org.civicoop.civirules/org.civicoop.civirules-master/CRM/Civirules/Trigger/Post.php(81): CRM_Civirules_Engine::triggerRule(Object(CRM_Civirules_Trigger_Post), Object(CRM_Civirules_TriggerData_Post))
#7 /var/www/clients/client1/web8/web/sites/default/files/civicrm/ext/org.civicoop.civirules/org.civicoop.civirules-master/CRM/Civirules/Trigger/Post.php(66): CRM_Civirules_Trigger_Post->triggerTrigger("create", "Event", 12, Object(CRM_Event_DAO_Event))
#8 /var/www/clients/client1/web8/web/sites/default/files/civicrm/ext/org.civicoop.civirules/org.civicoop.civirules-master/civirules.php(137): CRM_Civirules_Trigger_Post::post("create", "Event", 12, Object(CRM_Event_DAO_Event))
#9 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Utils/Hook.php(213): civirules_civicrm_post("create", "Event", 12, Object(CRM_Event_DAO_Event))
#10 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Utils/Hook/DrupalBase.php(87): CRM_Utils_Hook->runHooks((Array:33), "civicrm_post", 4, "create", "Event", 12, Object(CRM_Event_DAO_Event), NULL, NULL)
#11 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Utils/Hook.php(304): CRM_Utils_Hook_DrupalBase->invoke(4, "create", "Event", 12, Object(CRM_Event_DAO_Event), NULL, NULL, "civicrm_post")
#12 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Event/BAO/Event.php(110): CRM_Utils_Hook::post("create", "Event", 12, Object(CRM_Event_DAO_Event))
#13 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Event/BAO/Event.php(141): CRM_Event_BAO_Event::add((Array:28))
#14 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Event/Form/ManageEvent/EventInfo.php(307): CRM_Event_BAO_Event::create((Array:28))
#15 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Core/Form.php(345): CRM_Event_Form_ManageEvent_EventInfo->postProcess()
#16 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Core/QuickForm/Action/Upload.php(166): CRM_Core_Form->mainProcess()
#17 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Core/QuickForm/Action/Upload.php(133): CRM_Core_QuickForm_Action_Upload->realPerform(Object(CRM_Event_Form_ManageEvent_EventInfo), "upload")
#18 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Upload->perform(Object(CRM_Event_Form_ManageEvent_EventInfo), "upload")
#19 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Event_Form_ManageEvent_EventInfo), "upload")
#20 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Core/Controller.php(353): HTML_QuickForm_Page->handle("upload")
#21 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Utils/Wrapper.php(115): CRM_Core_Controller->run()
#22 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Core/Invoke.php(286): CRM_Utils_Wrapper->run("CRM_Event_Form_ManageEvent_EventInfo", "New Event", NULL)
#23 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:15))
#24 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
#25 /var/www/clients/client1/web8/web/sites/all/modules/civicrm/drupal/civicrm.module(489): CRM_Core_Invoke::invoke((Array:3))
#26 [internal function](): civicrm_invoke("event", "add")
#27 /var/www/clients/client1/web8/web/includes/menu.inc(527): call_user_func_array("civicrm_invoke", (Array:2))
#28 /var/www/clients/client1/web8/web/index.php(21): menu_execute_active_handler()
#29 {main}

I would really like some help debugging this error. Does anyone have any suggestions?

1

I think that you are discussing this problem at the moment on GitHub too? https://github.com/CiviCooP/org.civicoop.civirules/issues/90

It looks like you are passing a NULL value as a parameter to a function in the civirules logging. You could try to add a check for a NULL value in CRM/Civirules/Engine.php. Does this help? And great if you can fix this error in a PR on GitHub.

  • Indeed follow the discussion on github – Jaap Jansma - CiviCooP Jul 1 '16 at 13:14
  • 1
    Thanks Erik & Jaap I mainly posted this here to see if anyone else is experiencing these issues and if so what solution did they come up with. I am not coder but have troubleshoot issues in the past and fixed modules with help. I will continue discussions within github and once a solution is present I will Answer it here also for others searching with similar issues. – pacusi Jul 1 '16 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.