I am trying to use the MailGun extntion by teamsinger in WordPress ( Civicrm 4.7.11 )


The main issue I am facing is the webhooks back.

The documentation gives the path https://www.example.com/civicrm/mailgun/bounce

Which may well be appropriate for Drupal but not for WordPress.

The code seems to create a page for the hook.

Accessing that page manually


I can see that it is being reached via


(as it is giving the correct validation failure generated by the code )

The issue is I need MailGun to reach that page and Mailgun is not logged in of course and


returns with "Sorry, no content matched your criteria." response

I have turned off all plugins except CiviCRM & turned off permalinks and given "Master control for access to the main CiviCRM backend and API" to annoymous

All to no avail?

Any ideas?

1 Answer 1


OK Solved

The URL should be


AND permalinks must be turned on.

Annoymous access is not required (it seems) for this extension

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.