1

Failed to connect to smtp.tipping.org.au:25 [SMTP: Failed to connect socket: Connection timed out (code: -1, response: )].

WE have an internal mail server. Can resolve externally. Requires username and password authentication.

Tried most things we can think of to set up outbound email but get the above error message after sending test message

Have tried using mail(), appears to send test message successfully, but never received.

Grateful for advice on how we might correct outbound email settings.

1

Perhaps your internal mail server uses a different port for smtp? You can see that it's trying to connect to port 25, you might have it configured at a different port?

Alternatively, if you have some kind of command line interface to the machine running the civicrm code, you could try a direct connection using, for example, telnet (details here https://www.port25.com/how-to-check-an-smtp-connection-with-a-manual-telnet-session-2/).

And finally, you might also look at the dns on the civicrm code machine to make sure your domain for the smtp server is resolving like you expect, and/or trying putting in the ip of the mail server instead of its name.

  • Agreed on the last one! "Resolves externally but not internally" suggests that you need to connect on the private IP, not the external one. Your internal DNS server should return different results, or you can enable NAT Reflection on your router if it's an option. – Jon G - Megaphone Tech Jan 24 '17 at 14:13
  • 👍 to all the above. I also suggest checking your mail settings as shown in phpinfo(), and identify and watch the mail logs on the machine you're delivering from and to (if at all possible). Revealing what's actually happening with the email should clarify things quickly. – Chris Burgess Jan 24 '17 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.