3

I would like to install the Mosaico extension in a Windows server. It's possible? If yes there is a windows equivalent to setup.sh batch? Thanks

  • Yes it should be possible however not sure about the setup. Try mosaico.io for further installation details Many thanks Daniella – Daniella Apr 18 '17 at 13:30
  • 1
    Hi Marcello, what is the motivation for Windows? Is your own development machine windows or is it a requirement of the hosting provider. – Kainuk - CiviCooP Apr 19 '17 at 8:48
2

Is it possible? Yes, Mosaico is a client-side Javascript library that runs in the browser. It needs a PHP backend that runs on Windows.

Is it easy? No. Your starting point the setup.sh script runs only on Unix. However, it is not very complicated so that you can try executing the actions manually. But it is dependent on tools like git, npm and grunt, which are not standard on Windows. I expect they can al be installed on Windows, which is in a way make the machine more like Unix (you can even install Cygwin if you want to run the setup script.

Maybe the best way start with a Unix machine and get it working. The next step is to copy the extensions and the package directory to your Windows deployment server.

3

The setup.sh is only necessary to build Mosaico, since it's still in beta. You don't need it to actually run Mosaico. Just download a pre-built version here: http://dist.civicrm.org/extension/uk.co.vedaconsulting.mosaico/latest/uk.co.vedaconsulting.mosaico-latest.zip

  • Thank's Jon, I succeed in installation. But in all cases (Linux & Windows) where I installed Mosaico, when I drop an image, I obtain a Json parse error. Do you know if this is because of the beta level? – marcello May 3 '17 at 5:48
  • @marcello I don't know. You should look in your Dev Tools (press F12 in your browser) on the "Network" tab and look at XHR requests/responses to see if there's something malformed. Do you have PHP warnings/notices suppressed? – Jon G - Megaphone Tech May 3 '17 at 18:07
  • Not used to use that tool but: when uploading the image is in the form, at the end the state pass to 200 and the image disappear. Going through the XHR tools I found the error "Class 'Imagick' not found", I will work in this direction. Thanks – marcello May 5 '17 at 6:59
  • There are many issues on the CiviCRM Mosaico Github dealing with that error - in short, you need to install the ImageMagick tool AND the ImageMagick PHP extension. – Jon G - Megaphone Tech May 5 '17 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.