0

I am running CiviCRM version 5.43.0 on Wordpress 5.8.2 with PHP 7.4 - it's a new site, freshly installed.

We had Mosaico running (though in fact at the time I think we didn't have either GD or php-ImageMagick installed!) via the CiviCRM Extensions manager. FLexmailer, GD and php-ImageMagick are all now installed (for both PHP 8, and for 7.4).

On upgrade to 2.8, Mosaico is now generating errors. When opening CiviCRM, a modal appears:

Mosaico: Packages are missing Mosaico requires dependencies in its "packages" folder. Please consult the README.md for current installation instructions.

And if you go to Mailing > New Mailing a message appears:

Mosaico cannot be displayed because this system does not meet all requirements.

I have the CiviCRM log viewer extension installed, and this is not showing any errors. Google searches don't return anything obvious. I'd appreciate any assistance in debugging this error further - should I be asking this on Mosaico's boards instead? Many thanks!

Tried so far:

  • Install phpImageMagick
  • Install GD
  • Clear CiviCRM Caches
  • Server reboot (never hurts hey)
2

I managed to fix this by uninstalling the Extension in the CiviCRM manager, then deleting the uk.co.vedaconsulting.mosaico folder from the extensions folder, and then reinstalling via the Extensions Manager

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.