1

I'm new to civi and have had it dumped in my lap, so I know little about it. However, when I go to Adminster/System Setting/Extensions, I get a popup that says 'Your extensions require database updates. Please execute the updates' When I click 'execute the updates', the next screen says '[Error: Upgrade org.civicrm.module.cividiscount to revision 2201] DB Error: unknown error'

How can I figure out what the problem is?

  • CiviCRM version? CMS? Have you tried turning on error logging so that you get more information? – Jenni Simonis Feb 7 '18 at 0:27
  • We have civi 4.7.29 and we're using Wordpress, version 4.9.4. – kzburn Feb 8 '18 at 10:57
  • Sorry, I was editing my comment and it timed out.....We have civi 4.7.29 and Wordpress, version 4.9.4. How do I turn on error logging? I have some on but it isn't helping much. In wordpress, I get an error that a cividiscount file is not found even though it's there. I see the error when I inspect the page. In a civi log file, I get a "You do not have permission to access this page." error. We have a multisite configuration and it seems there is a permissions problem somewhere. Until these problems were dumped in my lap 2 weeks ago I had never looked at civi. Thanks! – kzburn Feb 8 '18 at 11:10
  • I'll post more info below in an answer, as then I can give a longer answer and such. – Jenni Simonis Feb 8 '18 at 14:13
1

I can only speak in generalities, as I use Drupal instead of WordPress. So some of these things might be in a different spot. You'll need to go to wherever WordPress has its permissions and set them there. It's possible that they have it set up so that all the permissions go through the main site or that they are individual to each site.

Here's where I turn on error handling on my install.

Error handling

Some options will tell you they are not recommended on a live site. That is because they slow down your site and may show errors to the general public. Usually if I am having issues, I will turn them on temporarily so that I can get the errors to show and then turn it off once I am done.

The extension not being found is likely due to one of two things:

  • The site is pointing to the wrong place for extensions.
  • Permissions for the files. I get this when I am logged in as root to the server, but the files need to be "owned" by the user assigned to the account.
  • Thank you! I'll turn on debugging and see what I find. – kzburn Feb 8 '18 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.