2

I hope someone can answer this! I've tried 30 various date formats, rearranged columns, and every time I do a membership import it fAils. No errors are presented, I'm just returned to "Upload Data (step 1 of 4)" from step 3... I never see step 4 (summary). In "plugins/files/civicrm/upload" folder I see a file "sqlImport.errors" which shows an error not recognizing the date formate for the membership start and end

But I've tried every format and none work. :(.

Each time one membership record (1 row) imports, and then if fails! Every time.

The first 2,5 lines of sqlImport.errors says:

Line Number","Reason","External Identifier (match to contact)","Membership Type Id","Email (match to contact)","Membership Start Date","Membership Expiration Date" "2","Invalid value for field(s) : Start Date; End date","33","Adult","wfsdfoks@telus.net","06/01/2013","06/01/2014" "3","Invalid value for field(s) : Start Date; End date","34","Youth","helsdfng@rebalasdftouch.com","06/01/2013","06/01/2015"

I've tried different formats of dates (yyyy-mm-dd, mm/dd/yy, mm/dd/yyyy, dd/mm/yyyy) and selected the appropriate format from Step 1 in the import page.

Every time it's the same: - I get to Step 3, and click "Submit" - 1 (one, only) row get imported (correctly) and then - I'm taken back to Step 1 - No error, complaint, nothing.

In my server's error log I see:

...client denied by server configuration: /home/civicthe/public_html/wp-content/plugins/files/civicrm/custom/delete-this-OcxGgONTcR ... client denied by server configuration: /home/civicthe/public_html/wp-content/plugins/files/civicrm/upload/delete-this-Zj1bvAyuTv ...client denied by server configuration: /home/civicthe/public_html/wp-content/plugins/files/civicrm/ConfigAndLog/CiviCRM.fee2178658acc8deae2211eadc328c3b.log

FYI, after each fail (1 row imports) I delete the top row from the .csv file and try again, and again 1 row imports, so it can't be the .csv file.

Can anyone help? This is driving me bonkers. Why does it fail if the next time I run the

  • The extra punctuation and allcaps are a turn-off. You'll have more success getting volunteer feedback with polite, civil language in your post. – Joe Murray May 13 '15 at 1:49
  • hehe thanks Joe. Mama said always chill out before posting questions to frustrating situations... I should have calmed down first. – Roger May 13 '15 at 16:53
1

Are you using WPSec or some other security related wordpress plugins? Check:

https://wordpress.org/support/topic/plugin-better-wp-security-client-denied-by-server-configuration

Seems like:

a. CiviCRM is trying to write something to the log file

b. The security plugin traps that and redirects you back to step 1

try disabling the plugins and see if that helps

  • Thanks for the idea, but no, we aren't using any extra security plugins. Any other ideas? – Roger May 13 '15 at 16:58
  • can you disable all WP plugins except for civicrm and try. The error is being issued by some code within your WP + plugin codebase most likely – Donald Lobo May 13 '15 at 18:18
  • 1
    Thanks everyone. the issue was indeed the JetPack plugin - once I disabled the "Notify" piece of that plugin the imports ran smoothly. Anyone know why Notify is causing problems? – Roger May 14 '15 at 22:53
0

What you pasted is hard to read, but I think there is an issue of mixing of column and semi-column. At least it's a problem I've already experienced: the separator isn't correct and so it concatenates too many columns as if it were a single one

What column separator have you selected?

Administer > Localization > Language, currency, location

(Import / Export Field Separator)

Check that it matches your csv (edit it under notepad to be sure)

  • Thanks for the suggestion, but nope - I'm using commas and have confirmed there are no extra comments in the small file I've been testing with. :-( – Roger May 13 '15 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.