1

I'm runnning the bitnami image on Google cloud (5.0.1), trying to get sms reminders working.

Provider Account is set up and tested, extension installed and configured, but when I send a test sms it is reported as delivered by Civi, but it's not, and nothing appears in the providers reporting either, so I assume there has been no actual communication with the gateway.

How can I troubleshoot this? Does the extension work with 5.1?

  • Ah, extensions weren't the problem, the problem was there were no recipients reported in the test group I was using, although there are quite a lot of contacts with telephone numbers in the group. I assume I must have to prepare the contacts in a different way to pick up their numbers? – Sean Kenny May 16 '18 at 11:24
  • Ok, number has to be labelled mobile, I didn't see that in the documentation. So I have contacts in the sms group now but still no sucessful sms mailings using either Twilio or Clikatel. Now going to try again with debugging turned on – Sean Kenny May 16 '18 at 12:22
  • I'm still no further along, I'm going to assume Clickatell is broke, there are no errors reported, but Clickatell reports no interaction. I have to purchase a "number" from Twilio before I can test it properly (they used to give away free test numbers apparently) but I'm loathe to stump up cash unless I know it will work, unless anyone has any other suggestions? – Sean Kenny May 16 '18 at 18:26
  • Sean - have you raised this on the Clickatell extension issues? We've done some work recently to allow old and new keys to work, would be good to have a look at why yours isn't working. github.com/veda-consulting/org.civicrm.sms.clickatell/issues – Parvez Saleh May 18 '18 at 13:57
  • Thanks Parvez, I did look at the issues list originally, thought the issue might be the characters in the API key (#15), but if that was the problem, I'd see something in the logs wouldn't I, not successful delivery reported – Sean Kenny May 21 '18 at 14:59
1

Aha, nothing wrong with either extension, after some time I finally noticed the timezone mismatch with the server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.