2

I can't get geocoding to work on a fresh install. Manually entering the lat,long works.

I've followed the instructions and steps one by one.

I configured all settings I found referenced on the instructions:

  • Address Preferences,
  • Geocoding Settings,
  • Job Settings.

I confirmed that map works (using default sample data, the contacts come with geolocation info). The map icon is shown and the map is displayed when the icon is clicked on.

I create a new contact or delete geolocation data from existing contacts. When I execute the geocoding job, the result is that the contacts addresses are parsed but none is geocoded:

Full message: 
Finished execution of Geocode and Parse Addresses with result: Success (Addresses
Evaluated: 2
Addresses Geocoded: 0
Street Addresses Parsed: 2
)

When I check on the Google Cloud Metrics console I can see that all my geocoding requests generated an error. However I can't find any log with details and the request is generated by CiviCRM.

Am I misssing some format for the address, field or step??? I've tried on 2 clean install sites and can't get it to work.

Help is appreciated.


See screen captures below:

Address Preferences:

Address Preferences

Geocoding Settings:

Geocoding Settings

Default Contact with Geolocation info, showing map icon:

Default Contact with Geolocation info

Geocoding Job Settings

Job Settings

Google Cloud API report:

Google Cloud Metrics

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.