4

I recently updated CiviCRM to 5.21.0 and have noticed a rather strange bug affecting the relationships function.

Specifically, when I go to add a new relationship to an individual the pop-up calendar that appears to specify the start/end of the relationship is in cyrillic (Russian).

As I'm using the default US english install, I'd rather the calendar appear in English... As such, I'd like to seek advice regarding what I might be able to do to fix the issue.

regards,

Robert

ps. My install details and a screenshot are below:

  • Database system : MySQL, MariaDB, or equivalent
  • Database system version : 5.5.5-10.1.43-MariaDB-0ubuntu0.18.04.1
  • PHP 7.2.24-0ubuntu0.18.04.1
  • Web server: Apache/2.4.29 (Ubuntu)
  • Drupal 7.69
  • CiviCRM 5.21.0.

enter image description here

  • What are your settings at Administer - Localication - Languages? Also it's interesting you have duplicate calendar icons in that screenshot (to the right of the textbox). Normally there's only 1 icon per field. – Demerit Jan 8 at 19:26
  • @robert is your computer set to Russian language at all? – Seamus Lee Jan 8 at 21:22
  • Thanks for the comments - I've used a default (English-US) install and haven't turned on Russian in any way. I have though installed the Canadian English Language pack for CiviCRM. As for my localization settings, they are as follows: Default Language : English (Canada), Default language for contacts (Use default site language), – Robert Guerra Jan 9 at 19:10
  • In an attempt to assess if there's an issue with the CiviCRM code or my data (mysql), I did a fresh/clean install of Drupal 7x and CiviCRM on my machine. I used a separate database for drupal and Civicrm . Both were installed and working. I then replaced the CiviCRM database with a copy from my online server. The Russian calendar issue - appears. So I have been able to replicate the problem. I don't know yet though if it's an issue with a corruption in my database or an issue with the CiviCRM code.. :( – Robert Guerra Jan 9 at 22:01
  • 1
    I tracked down the issue - The Russian text seems to be caused by the Calendar (com.agiliway.civicalendar) CiviCRM extension. disabling it, fixed the issue. – Robert Guerra Jan 10 at 16:15
2

I've tracked down what caused the - duplicate calendar icons . It was an outdated version of the CiviCRM Shoreditch extension that was installed. I've disabled, uninstalled and deleted it. The duplicate icons are gone, the Russian text still remains though.

I have posted a ticket on the Shoreditch extension github site with the details. Hopefully they can resolve the issue. In the meantime, i've disabled the extension.

| improve this answer | |
  • Robert - do you mean posted a ticket on the com.agiliway.civicalendar extension github? You have mentioned above that this is not a shoreditch issue? – Jamie Novick Jan 14 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.