4

We recently upgraded to 4.6.3, and now the reply-to email address in CiviMail e-mails defaults to the system e-mail, not the From sender e-mail address, as previously. I could not duplicate on the demo site (at http://d46.demo.civicrm.org ), perhaps because the demo site is running 4.6.5.

A real bummer, any help fixing appreciated. Was this a 4.6.3 bug that has now been fixed in 4.6.5?

Thanks.

  • I'm noticing this as well. It doesn't apply to individual emails, but all emails sent from CiviMail are FROM the correct address but show the wrong REPLY TO address. Haven't dug into the code yet ... – Eliot Mason Jul 8 '15 at 22:11
  • Eliot, thanks for confirming the bug - are you also on 4.6.3, Drupal? – Joe McLaughlin Jul 8 '15 at 23:08
  • yes, same version. The FROM address is replaced with a VERP if that's selected. – Eliot Mason Jul 8 '15 at 23:52
  • Eliot, I think I figured it out, partly - in Administer > CiviMail > Mailer Settings choose Yes for "Enable Custom Reply-To - Allow CiviMail users to send mailings with a custom Reply-To header." That then adds a custom Reply To selection in the new or saved draft CiviMail settings. Unfortunately the Yes selection does not seem to get saved in the Mailer Settings. But - some progress. – Joe McLaughlin Jul 9 '15 at 0:13
  • Joe - that setting might overcome the problem, but its not the source. I upgraded my client to 4.6.4 and the problem seems to be be gone (without touching those settings). – Eliot Mason Jul 10 '15 at 0:54
4

This does indeed appear to be a bug in 4.6.3. Upgrading to 4.6.4 will fix the problem.

Note that additional functionality in CiviMail can affect the from: address: Using VERP or the custom reply-to header.

  • Thanks Eliot, wanted to make sure you got the points for the answer – Joe McLaughlin Jul 11 '15 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.