0

I am setting up a new install of CiviCRM on the latest Wordpress (self hosted). I am trying to set up membership types, but when I go to enter the Membership Organization, I get a "Loading failed" message (see screenshot). I have already created two contact records of type Organization, including the default org which this setup is for. I am logged in as the super admin, so it should not be a permissions error. Also, there are no existing membership types. Any ideas appreciated. Thanks.

enter image description here

6
  • If I can't get past this step, I can't use CiviCRM at all for this site. Anyone have any ideas please? Mar 2, 2022 at 19:36
  • 1
    check civicrm error log - That should give you an idea
    – Ramesh
    Mar 3, 2022 at 11:41
  • Thanks for the suggestion Ramesh. Unfortunately, there is nothing in ConfigAndLog. I tried it with debugging and backtrace turned on as well. Is there another place I should be looking? Mar 3, 2022 at 16:01
  • 1
    Enable wp_debug and see if you are getting any PHP error
    – Ramesh
    Mar 4, 2022 at 14:10
  • Thanks for the suggestion Ramesh. I tried that, but no errors appeared when I tried to add a new membership type and got "loading failed" again. It's a strange mystery! Mar 4, 2022 at 19:17

1 Answer 1

2

Well, I finally tracked this down. But before I go into that, I should say that I initially worked around the issue by creating the Membership Types right in the Civi table using phpMyAdmin.

Later, though, I noticed I was getting the same "Loading failed" when trying to add a tag to a contact using the tag tree popup. I also could not create a new mail message. It always got stuck on "initializing." So I went searching for more help and found an old post on the CiviCRM community forum by @Coleman that seemed to be related to the issues I was experiencing.

Based on that post, I started to disable WordPress plugins. I narrowed it down to the All In One WP Security plugin. Then I narrowed it down to the plugin's firewall measures. Finally, I found the culprit, the "Enable legacy 5G Firewall Protection" setting. By unchecking that, I was able to restore proper functionality in CiviCRM.

I hope this helps someone else out there who might be getting "loading failed" issues. It will most likely be related to the firewall and what is in the .htaccess file.

Thanks again to those of you who offered help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.