0

This happens on Civicrm for Joomla. It prevents both upgrading to Php 8 and upgrading to latest Civicrm, as doing any of these stops the cron job.

This is what I see with Civicrm 5.49.3:

$ php74 domains/figg.org/public_html/administrator/components/com_civicrm/civicrm/bin/cli.php -s figg.org -u cronjob -p DeveFarl0 -e Job -a execute
PHP Deprecated:  Non-static method JApplication::getMenu() should not be called statically in /home/usiako1s/domains/figg.org/public_html/plugins/authentication/civicrm/civicrm.php on line 305

$ php81 domains/figg.org/public_html/administrator/components/com_civicrm/civicrm/bin/cli.php --help
PHP Fatal error:  Array and string offset access syntax with curly braces is no longer supported in /home/usiako1s/domains/figg.org/public_html/administrator/components/com_civicrm/civicrm/packages/DB/common.php on line 265

Using the latest Civicrm, the first example (with php74) generates the string "Error", and I was not able to pinpoint where it fails (I don't speak Php).

1 Answer 1

1

There was a problem with cli.php and cv in 5.57.0 on Joomla. That is fixed in 5.57.1 just released.

For php versions, see the notes at https://docs.civicrm.org/installation/en/latest/general/requirements/#php You're probably better sticking with 7.4 for now.

3
  • I upgraded to 5.57.1 and I get these warnings: WARNING: Class Civi\Api4\Event\Subscriber\ActivityPreCreationSubscriber was expected to have a service definition, but it did not. Perhaps it needs service name. Same for classes: Civi\Api4\Event\Subscriber\ContributionPreSaveSubscriber was... Civi\Api4\Event\Subscriber\CustomGroupPreCreationSubscriber was ... Class Civi\Api4\Event\Subscriber\OptionValuePreCreationSubscriber was ... PHP Deprecated: Non-static method JApplication::getMenu() should not be called statically in .../civicrm.php on line 305 Jan 13, 2023 at 14:02
  • Are you on J4? I don't think that's officially supported yet although work has gone into making it work. Do log those warnings at lab.civicrm.org/dev/joomla/-/issues
    – Aidan
    Jan 13, 2023 at 15:07
  • No, it's J3. I posted a bug report at lab.civicrm.org/dev/joomla/-/issues/44 Jan 14, 2023 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.