1

I restored my site from an Akeeba backup and now I cannot access the site's backend administration panel. Mysite.org/administrator opens the login screen, but I get a 500 error when I try attempt to log in.

Hosting provider: Hostmonster.com Joomla 3.10.12 MySQL Version: 5.7.23-23 PHP Version: 7.4 CiviCRM Verson: 5.49.1

I created a new database and user for the Joomla restore. I had a similar issue once before in a restore so I checked both civicrm.settings.php files. Both files had the old db name, username, and password. I've updated those files with the new db name, username, and password, but I still cannot enter the backend administration. I believe there was another step I took to get the backend working, but I don't remember what it was.

The restored site error log reports:

[02-Aug-2023 14:25:11 America/Boise] PHP Fatal error:  Array and string offset access syntax with curly braces is no longer supported in /home2/name/public_html/domain/administrator/components/com_civicrm/civicrm/packages/DB/common.php on line 265

The civicrm.config.php file located in public_html/domain/administrator/components/com_civicrm/civicrm/ contains the following:

<?php
define('CIVICRM_SETTINGS_PATH', '/home2/name/public_html/domain/administrator/components/com_civicrm/civicrm.settings.php');
$error = @include_once( '/home2/name/public_html/domain/administrator/components/com_civicrm/civicrm.settings.php' );
if ( $error == false ) {
    echo "Could not load the settings file at: /home2/name/public_html/domain/administrator/components/com_civicrm/civicrm.settings.php
";
    exit( );
}

// Load class loader
require_once $civicrm_root . '/CRM/Core/ClassLoader.php';
CRM_Core_ClassLoader::singleton()->register()

Having fixed this once before, but not remembering exactly how, I believe I'm not too far from getting this fixed.

How do I get CiviCRM to point to the new db name, username, and password?

Mike

1 Answer 1

0

When I tried loging into the backend of my restored site this morning it worked. I didn't change anything in any CiviCRM files after my previous post.

I'm not sure if a cache was cleared or what, but I have access to the backend again.

Mike

1
  • 1
    The file civicrm/packages/DB/common.php shouldn't exist since it's now under civicrm/vendor/pear/db. It sounds like you still have copies of older files which are conflicting. I expect you'll see it keep coming up intermittently since sometimes it will load the newer file and sometimes the older. See the paragraph after step 4 here: docs.civicrm.org/sysadmin/en/latest/upgrade/joomla/…
    – Demerit
    Aug 3, 2023 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.