kcfinder is not allowing me to browse or upload images. I get this error:

Sorry but we are not able to provide this at the moment. You must be logged in with proper permissions to edit, add, or delete uploaded images.

I am logged in as User 1. It seems that kcfinder does not know that I am logged in.

enter image description here

  • Note that in Drupal 7, the concept of the Drupal superuser (user/1) is obsolete; you select the admin role from among the standard roles, and can assign it to any number of accounts to it.
    – choster
    Commented Jan 15, 2016 at 15:47

2 Answers 2


It turned out that our was a permission issue. I'm on Pantheon so I want able to change the permissions on the directory I was using, so I changed directories for uploads and it worked


you need to create a settings.localtion.php file in your civicrm directory

then have

define('CIVICRM_CONFDIR', 'directory where civicrm.settings.php is');

  • I created a file with this: <?php define('CIVICRM_CONFDIR', '/code/sites/default/'); ?> I called the file settings.location.php and also tried calling it settings_location.php The error still persists
    – Yossi
    Commented Nov 3, 2015 at 5:26
  • in your define you want the full path right from the server's root and then ending at sites/default' I don't think you need the ?> at the the end tho
    – Seamus Lee
    Commented Nov 4, 2015 at 19:56
  • see here wiki.civicrm.org/confluence/pages/…
    – Seamus Lee
    Commented Nov 4, 2015 at 19:57
  • The error changed to this : Could not find valid configuration dir, best guess: /code/sites/default/ then We fixed it and corrected the file to this: <?php if (!empty($_SERVER['PRESSFLOW_SETTINGS'])) { $env = json_decode($_SERVER['PRESSFLOW_SETTINGS'], TRUE); if (!empty($env['conf']['pantheon_binding'])) { $pantheon_conf = $env['conf']; $civicrm_conf = '/srv/bindings/' . $pantheon_conf['pantheon_binding'] . '/code/sites/default'; define('CIVICRM_CONFDIR', $civicrm_conf); } } Now we are back to the old error...
    – Yossi
    Commented Nov 4, 2015 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.