4

Running D7 and Civi 4.6.10. When I create an Event and go to enable Online Registration it will not save. It sits and spins. If I refresh the page it will give an error that says Profile is not assigned to this event. I've tried all different configurations on the Online Registration screen but nothing will allow it to save. Any ideas as to what is causing this?

The error I kept getting is below. I disabled CiviRules and it works like it's supposed to. I have the CiviRules master from 10-15-15 installed.

CiviCRM_API3_Exception: "id is not a valid integer"

#0 /home/mydomain/civicrm_extensions/org.civicoop.civirules/CRM/Civirules/Utils/CustomField.php(25): civicrm_api3("CustomField", "getsingle", (Array:1))
#1 /home/mydomain/civicrm_extensions/org.civicoop.civirules/CRM/Civirules/Utils/CustomDataFromPre.php(37): CRM_Civirules_Utils_CustomField::isCustomFieldMultiselect("pre")
#2 /home/mydomain/civicrm_extensions/org.civicoop.civirules/CRM/Civirules/Utils/CustomDataFromPre.php(19): CRM_Civirules_Utils_CustomDataFromPre::setCustomData("Event", "pre", "18", "id")
#3 /home/mydomain/civicrm_extensions/org.civicoop.civirules/civirules.php(133): CRM_Civirules_Utils_CustomDataFromPre::pre("edit", "Event", "286", (Array:38))
#4 /home/mydomain/sites/all/modules/civicrm/CRM/Utils/Hook.php(215): civirules_civicrm_pre("edit", "Event", "286", (Array:38))
#5 /home/mydomain/sites/all/modules/civicrm/CRM/Utils/Hook/DrupalBase.php(87): CRM_Utils_Hook->runHooks((Array:166), "civicrm_pre", 4, "edit", "Event", "286", (Array:38), NULL, NULL)
#6 /home/mydomain/sites/all/modules/civicrm/CRM/Utils/Hook.php(282): CRM_Utils_Hook_DrupalBase->invoke(4, "edit", "Event", "286", (Array:38), NULL, NULL, "civicrm_pre")
#7 /home/mydomain/sites/all/modules/civicrm/CRM/Event/BAO/Event.php(92): CRM_Utils_Hook::pre("edit", "Event", "286", (Array:38))
#8 /home/mydomain/sites/all/modules/civicrm/CRM/Event/Form/ManageEvent/Registration.php(850): CRM_Event_BAO_Event::add((Array:38))
#9 /home/mydomain/sites/all/modules/civicrm/CRM/Core/Form.php(345): CRM_Event_Form_ManageEvent_Registration->postProcess()
#10 /home/mydomain/sites/all/modules/civicrm/CRM/Core/QuickForm/Action/Upload.php(166): CRM_Core_Form->mainProcess()
#11 /home/mydomain/sites/all/modules/civicrm/CRM/Core/QuickForm/Action/Upload.php(133): CRM_Core_QuickForm_Action_Upload->realPerform(Object(CRM_Event_Form_ManageEvent_Registration), "upload")
#12 /home/mydomain/sites/all/modules/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Upload->perform(Object(CRM_Event_Form_ManageEvent_Registration), "upload")
#13 /home/mydomain/sites/all/modules/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Event_Form_ManageEvent_Registration), "upload")
#14 /home/mydomain/sites/all/modules/civicrm/CRM/Core/Controller.php(353): HTML_QuickForm_Page->handle("upload")
#15 /home/mydomain/sites/all/modules/civicrm/CRM/Utils/Wrapper.php(115): CRM_Core_Controller->run()
#16 /home/mydomain/sites/all/modules/civicrm/CRM/Core/Invoke.php(286): CRM_Utils_Wrapper->run("CRM_Event_Form_ManageEvent_Registration", "Event Online Registration", NULL)
#17 /home/mydomain/sites/all/modules/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:14))
#18 /home/mydomain/sites/all/modules/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:4))
#19 /home/mydomain/sites/all/modules/civicrm/drupal/civicrm.module(489): CRM_Core_Invoke::invoke((Array:4))
#20 [internal function](): civicrm_invoke("event", "manage", "registration")
#21 /home/mydomain/includes/menu.inc(527): call_user_func_array("civicrm_invoke", (Array:3))
#22 /home/mydomain/index.php(21): menu_execute_active_handler()
#23 {main}

Sorry but we are not able to provide this at the moment.
id is not a valid integer

EDIT: This issue was reported to the github issue qeue and I did verify that it's occurring on the demo version at http://dmaster.demo.civicrm.org. The response I received was that it wasn't happening on the developers site and so they weren't concerned with fixing it unless someone paid them.

  • 1
    Firstly, dmaster.demo is running 4.7 and the people who developed CiviRules have said it should work on 4.4 and 4.6 but have never said it will work on 4.7. Secondly, CiviRules is a fantastic extension that has been funded by two or three organisation. It isn't part of core and there is no obligation on the people who have provided it to make it work on every installation. Free software is not like free beer it is like free kittens. You have to feed a kitten and if it gets sick you can treat it yourself, take it to a vet or choose to let it die if you aren't prepared to spend any money. – JoAnne Jan 22 '16 at 5:03
  • You seem to be running the version of CiviRules from October 2015. Have you tried running the latest version of CiviRules (V1.2) that was released on 15 Dec 2015 and has been tested with CiviCRM 4.6.10? – JoAnne Jan 22 '16 at 5:17
  • Yes, I downloaded 1.2 and tried it and also the master branch and tried it. same error for both. – frTommy Jan 22 '16 at 5:42
  • I just checked the d46.demo.civicrm.org demo and it gives the same error. – frTommy Jan 22 '16 at 5:51
2

Did you included any profile for event registration page?? If yes then check profile is active or not. It will be help if you provide snapshot of the error as well as configuration page.

  • Yes I included the basic profile of Individual Prefix, First Name, Last Name, Email Address. I've tried it with every sort of configuration, changing to different profiles, just enabling online registration and not changing any setting. Always get the same error. – frTommy Dec 30 '15 at 3:09
  • I figured it out. See my original question. – frTommy Dec 30 '15 at 3:16
1

It was CiviRules. See orginal question for details.

  • As JoAnne commented, CiviRules is an extension that has been funded by a couple of organization and has been shared. This particular issue has been reported by a number of people. It can probably be fixed quickly but so far no one has taken the trouble of fixing or funding it. So the free kitten is not fed :-) – ErikH - CiviCooP Feb 22 '16 at 8:31
1

I have fixed this issue in the Civirules module. So if you experience this issue it might be worth upgrading civirules to the latest version.

See also: https://github.com/CiviCooP/org.civicoop.civirules/issues/55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.