1

I'm having trouble getting the email to activity processing to work. (Wordpress 4.4.4 and Civi 4.6.4) I keep getting this error:

Could not connect to MailStore for XXX@domain.org@imap.gmail.com<p>Error message: <pre>An error occured while sending or receiving mail. Failed to connect to the server: imap.gmail.com:993.</pre><p>

 $backTrace = #0 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(322): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Utils/Mail/EmailProcessor.php(184): CRM_Core_Error::fatal("Could not connect to MailStore for xxxx@domain.org@imap.gm...")
#2 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Utils/Mail/EmailProcessor.php(111): CRM_Utils_Mail_EmailProcessor::_process(FALSE, Object(CRM_Core_DAO_MailSettings))
#3 /myfolder/wp-content/plugins/civicrm/civicrm/api/v3/Job.php(379): CRM_Utils_Mail_EmailProcessor::processActivities()
#4 /myfolder/wp-content/plugins/civicrm/civicrm/Civi/API/Provider/MagicFunctionProvider.php(89): civicrm_api3_job_fetch_activities((Array:1))
#5 /myfolder/wp-content/plugins/civicrm/civicrm/Civi/API/Kernel.php(96): Civi\API\Provider\MagicFunctionProvider->invoke((Array:9))
#6 /myfolder/wp-content/plugins/civicrm/civicrm/api/api.php(23): Civi\API\Kernel->run("job", "fetch_activities", (Array:1), NULL)
#7 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Core/JobManager.php(131): civicrm_api("job", "fetch_activities", (Array:1))
#8 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Core/JobManager.php(110): CRM_Core_JobManager->executeJob(Object(CRM_Core_ScheduledJob))
#9 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Admin/Page/Job.php(155): CRM_Core_JobManager->executeJobById("3")
#10 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Core/Page/Basic.php(178): CRM_Admin_Page_Job->browse(NULL, NULL)
#11 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Admin/Page/Job.php(140): CRM_Core_Page_Basic->run()
#12 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(312): CRM_Admin_Page_Job->run((Array:3), NULL)
#13 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:13))
#14 /myfolder/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
#15 /myfolder/wp-content/plugins/civicrm/civicrm.php(1189): CRM_Core_Invoke::invoke((Array:3))
#16 [internal function](): CiviCRM_For_WordPress->invoke("")
#17 /myfolder/wp-includes/plugin.php(525): call_user_func_array((Array:2), (Array:1))
#18 /myfolder/wp-admin/admin.php(236): do_action("toplevel_page_CiviCRM")

We use google apps to host our mail and I've read through the posts on here already regarding that set up. I don't think it's google apps that's tripping things up. I get this same error message with any email set up I try. Here's what I've done to try and narrow down the problem - all of these result in the same error "could not connect to MailStore"

  • Used emails hosted through GoDaddy and Hostmonster.
  • Tried both IMAP and POP3 settings
  • Turned on and off SSL
  • Cleaned the email accounts I was testing (i.e. they only had one or two emails in the account)
  • To see if a different error would populate, purposefully used the wrong password.

Can anyone suggest what I might need to look for? I'm not sure I know what the rest of the backtrace means....

Thanks!

1

Sounds like firewall is blocking port 993. Do you use outlook or a desktop email program with imap? Does it work there? Do you know how to use telnet to test - can you telnet to port 993?

  • I didn't know how to test but a google search got me what I needed (thanks, another tool in my belt). I ran an imap (993) test and get the following result: "OK Gimap ready for requests" so I'm guessing that yes, it works. – RayWright Jul 6 '16 at 14:14
  • Just checking you tried that test FROM THE SERVER? – Demerit Jul 6 '16 at 14:51
  • Whoopsie, no I hadn't, which it's clearly the important part (thus the reference to a firewall, right?) When I try to run the telnet imap test (on the server this time ;), the connection just times out. Is this a sign it's a firewall. I imagine I have to contact my host at this point? – RayWright Jul 6 '16 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.