1

Interesting situation... we use BeeFree to compose responsive emails, however they are failing to send, resulting in a scheduled/sent email as "running". We use EasyCron to trigger the scheduled jobs, however when using a BeeFree template, only the starting job is visible in the log, hence we see:

Entity: Job Action: process_mailing Summary Starting execution of Mailings scheduler Details Parameters parsed (and passed to API method): a:1:{s:7:"version";i:3;} Full message: Starting execution of Mailings scheduler

But we never see the "finished execution" message. I suspect this is why the status of the emailing is perpetually set to "running". If we try to then trigger the cron via the URL, the result is an internal server error 500.

Here's where it's interesting... if we compose a new HTML email and just drop some text in there, along with the require tokens, everything works perfectly. If we review the cron logs provided by EasyCron we see that the only difference between the successful and failed jobs (in the logs) is that the successful job log has this additional line:

X-Proxy-Cache: BYPASS

The log of the failed job does not have this line. I know this is probably way out there as far as an issue, however any insight into this would be great. We're running CiviCRM 4.7.11

  • 1
    I think this might be related to the CSS brackets {} in the <style></style> tag a the top of your email source code, and/or Smarty enabled in CiviMail, can you try removing entirely the style tag? I think BeeFree already does inline styling, so it should not affect the formatting of the email. – Andrei Oct 3 '16 at 20:04
  • Andrei, you nailed it. We did recently enable smarty. Removing the style tags (and everything in between) corrected the issue. Thank you. – Second Chance Oct 3 '16 at 20:12
  • Glad it helped, I'll add it as answer so we keep SE happy. – Andrei Oct 3 '16 at 20:14
  • would be good if Second Chance accepted the answer – petednz - fuzion Nov 2 '16 at 20:57
2

I think this might be related to the CSS brackets {} in the <style></style> tag a the top of your email source code, and/or Smarty enabled in CiviMail.

Removing entirely the style tag should fix the issue.

I think BeeFree already does inline styling, so it should not affect the formatting of the email.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.