2

I just upgraded to CiviCRM 4.7.16 (Wordpress 4.7.2) and my WYSIWYG editor has disappeared from the CiviMail editor. The HTML email only allows me to enter raw HTML.

Any idea what happened and how I can restore the WYSIWYG editor?

The mystery of the missing WYSIWYG editor

3 Answers 3

3

Well, it works again through magic and voodoo. All I did was go to the Wordpress Access Control page as Christia recommended and clicked "Save". I didn't modify any settings. Just clicking "Save" seems to have reconnected everything.

http://www.YOUR-ORG.com/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Faccess%2Fwp-permissions&reset=1

Wordpress Access Control

2
2

What WYSIWYG editor are you using? IF CKEditor, reestablish roles and permissions for the CKEditor by going into the configuration settings for text editors on your CMS side and make sure it's still set as the default editor. This is what I had to do after updating to 4.7.15.

Here is a screenshot on Drupal to give you an idea of what I mean. If someone can post/edit this post with the WP version, that would be great.

enter image description here

For Wordpress, check this: enter image description here

Also, you could check the Wordpress user roles and permission from CiviCRM under Administer > Users and Permissions > Permissions (Access Control). It might be different in WordPress, but I would check that first.

I know Wordpress is really different so I'm not sure how helpful this would be for you but the bottom line is to find the settings for making sure it's still default and can still be used by the intended users.

4
  • I'm using the default CKEditor. I'm using an Admin account, so there's no permissions to be given at the Wordpress level. Hmmmm... Feb 4, 2017 at 1:43
  • What I mean is this: find the configuration settings for CK Editor and make sure that all designated users can use it, including admin and make sure it is the default editor still. I reorganized my answer.
    – Christia
    Feb 4, 2017 at 1:46
  • 1
    Christia, you set me on the right path. Thanks! Feb 4, 2017 at 19:22
  • Don't forget to post your answer for what worked for you. :)
    – Christia
    Feb 5, 2017 at 1:51
0

Please double-check that you don't have the (Civi-)extension CKEditor4 disabled. This was my fault, because i tried to work with CKEditor5 instead. Both activated at the same time is working fine, only CKEditor5 without 4 won't.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.