2

I have two instances of WordPress (both running 4.7.4).

I have tried on one to install CiviCRM 4.6.27 and the other, CiviCRM 4.7.18. But, I get the same error: I try to install, I get all clear for the test to the DB and FileSystem, but after clicking on the « Check Requirements and Install CiviCRM » button, the browser just keep on loading the page with no success nor error messages.

I've install the plugin « Error Log Monitor » but I see nothing. Also, the file civicrm.settings.php in the upload/civicrm folder doesn't exists.

I get this in my apache error log file:

2017-04-24 01:44:09.900 [INFO] [24.114.88.1:53124] Connection idle time: 91 while in state: 10 stream flag: 0,close!
2017-04-24 01:44:09.900 [NOTICE] [24.114.88.1:53124] Content len: 215, Request line: 'POST /wp-admin/options-general.php?page=civicrm-install HTTP/1.1'
2017-04-24 01:44:09.900 [INFO] [24.114.88.1:53124] Cookie len: 522, wordpress_efc9291620b9675fe124bc49dffdbee0=admin%7C1494220081%7Co5FUUWceWVXphjqDGUCDRikjuFvBeiZ9HSUbfxuKt7r%7Cf2762fb5071fa7a4a6f9dcc220b8402c3852569d55f33b951e942f84912bd462; _ga=GA1.2.118246024.1491536971; PHPSESSID=a81gmdbmehahoikdne82n1ehv2; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_efc9291620b9675fe124bc49dffdbee0=admin%7C1494220081%7Co5FUUWceWVXphjqDGUCDRikjuFvBeiZ9HSUbfxuKt7r%7C1f32a1947ae120408e5bd791386098b6fd1d01e0c86ab85ca52f7b885b6c2a1b; wp-settings-time-1=1493012558;wp-settings-1=deleted
2017-04-24 01:44:09.900 [INFO] [24.114.88.1:53124] HttpExtConnector state: 8, request body sent: 215, response body size: -1, response body sent:4529, left in buffer: 0, attempts: 0.
2017-04-24 01:44:09.900 [INFO] [24.114.88.1:53124] Lsapi connection state: 3, watching event: 25, respState: 5, m_iTotalPending:0, m_iPacketLeft:0, m_iCurRespHeader:8, req sent for 91 seconds,Total processing time: 91.
2017-04-24 01:44:09.900 [INFO] [24.114.88.1:53124] Abort request processing by PID:410255, kill: 1, begin time: 91, sent time: 91, req processed: 0

I'm on a provider's machine, a CentOS 6.0 64 bit. WordPress seams to work fine.

Issue? Where to look?

Regards, Antoine

1

In your php.ini, what is your max_execution_time? I think the default may be 30 (sec) you may want to increase that. Also I think at least with Civi 4.7 the install will try to install in the WP database, are you 1) selecting a different database (and user) or 2) using the WP one? Are ANY tables ending up installed for Civi?

  • 1) same db 2) theses tables get created: civicrm_acl to civicrm_worldregion (107 tables). – Antoine Beaubien Apr 25 '17 at 0:56
  • I checked with phpinfo(), and the execution_max is at 600(s). – Antoine Beaubien Apr 25 '17 at 1:53
  • That last line of your Apache log indicates that some process in the hosting environment is killing things off at 90 seconds. That may not be sufficient. – Chris Burgess Apr 25 '17 at 3:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.