6

On a civi 4.7.19 / joomla 3.70 installation I have problems accessing events after the 4.7.19 ugrade (events worked OK on 4.7.18/3.7.0). I have current events displaying on the front page via the civievent module that can't be 'seen' in the event dashboard (no current events showing) or in Manage Events (only some old events show here). If I 'Search All', I get a 'None Found' message even though there is also a message saying 'Event 1-50 of 224'. When I try plugging the ID of a current event into the edit URL for one of these old events I get the error 'You do not have permission to access this page'. In case it's important, I have a 'Performance warning: Missing indices' alert on the status page, but the 'Update Indices' button does not seem to achieve anything as it comes back after confirming an update with the same Missing indices alert.

  • I have exactly the same problem using drupal 8.3.2 and civicrm 4.7.19. Can you create an issue for this in JIRA? – Richard van Oosterhout May 8 '17 at 5:43
  • Have either of your replicated on the Demo sites. That would be helpful step to take. – petednz - fuzion May 8 '17 at 19:59
  • I don't see a Joomla / civi 4.7 demo site. The drupal demo seems to show current events OK, but it's running 4.7.20… – Bryan May 8 '17 at 22:11
  • It seems that this may be related to link as the recommended action there:cv ev 'print_r(CRM_Core_BAO_SchemaHandler::getMissingIndices())' shows missing indices on the events table, which cant be fixed using the recommended course because of this link – Bryan May 8 '17 at 22:41
  • I just upgraded my dev site to 4.7.19 on Drupal 7, and it's the same deal. The blue bar shows with pagination, but no events show up. – Paul B May 8 '17 at 23:19
2

I'm seeing this too. Interestingly, if I click the "Last" link, i.e. to jump to the oldest events, I can see the first 20 or so oldest events. And these events can be edited. But none of the more recent events can be listed or edited.

I reproduced this on the demo site @ dmaster.demo.civicrm.org/civicrm/event/manage/… - to reproduce, requires having more than 25 events.

A fix is to add 'options' => array('limit' => 0), to the civicrm_api3() calls in CRM/Event/BAO/Event.php - the bug is caused by the default limit of 25 in API calls.

4

There is now an open issue and fix for this: https://issues.civicrm.org/jira/browse/CRM-20549

3

The problem is solved now. There are a few commits made made on the file so I thought of giving here the quick way instead of following all the thread.

To solve it, go to https://github.com/civicrm/civicrm-core/pull/10325/files and click on View to download the whole raw file as there are other modifications made to the file Event.php in CRM/Event/BAO/ since the release 4.1.9.

Make a copy of Event.php and change the whole file on your site.

Tested and it works.

Thanks to the whole team who worked on and solved the problem.

  • Thanks for the reader's digest of the solution ... super easy to apply – MtnPavlas May 18 '17 at 0:48
  • That's what I thought. The information was there but you had to read several posts to get it right. I wish it existed when I started. :) – danielchat May 30 '17 at 20:20
0

I too am experiencing this. Events are shown on the front end but in the back end, none are listed. I did notice, however, the alphabet link across the top appears to link to events, however, the same result occurs where no events are actually displayed.

0

Some additional information on the issue. (Using Joomla 3.6.5 and civicrm 4.7.19)

The manage events doesn't show any event and displays the message None found (see below). The events are working well on the front end.

List of events

We checked the api interface and this one is working as well.

API finding the events

If you create a report for events, you can find them as well in the drop down list of the filters.

It looks like the issue is only limited to the Manage Events page and not spread in other areas.

Hope it helps narrowing down the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.