I'm using Civicrm v4.7.19 on Drupal,

for using another language (like ES/DE) I've been creating directory: /public_html/sites/all/modules/civicrm/l10n

And the "mo" files placed in these addresses [both for testing]: /public_html/sites/all/modules/civicrm/l10n/es_ES/civicrm.mo /public_html/sites/all/modules/civicrm/l10n/de_DE/LC_MESSAGES/civicrm.mo

But the Localization settings page don't show the languages.




Can you check:

  • Go to Administer > System Settings > Option Groups
  • Then search for "Languages" and click on its "Options" link.
  • Double-check that the language is enabled.

Otherwise, it might be a file permission issue: can you check to make sure that the web server has permission to read the l10n directory and files?

  • Thanks for your response, I've been enabled Persian language (and other languages like Spanish) before, but it doesn't shows any language except English
    – Davodm
    Jul 2 '17 at 3:11
  • I opened this issue to track the bug: issues.civicrm.org/jira/browse/CRM-20803
    – bgm
    Jul 4 '17 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.