I've been running certain 5.6 for a long while and wondering if I ever should migrate to 7.0 or just leave alone. Installation instructions say 7.0 is recommended but so is 5.6

Anyone have opinions on this?

---Update: I have upgraded my WordPress site to 7.2 without too much trouble. However the Drupal 7 / Civi site when I tried to update, I got 503 errors and had to roll back. I think there are some really tight controls the consulting firm put into place. I kept reading about FastCGI and NGINX and had no idea. I do not know about these and if they are used. I know that FPM is used. I want to update before year end but I am scared. Anyone?

  • Thank youb to the first answer. It was very good. Read articles Apr 22, 2018 at 8:58

1 Answer 1


A few considerations:

1) You want to be running a version that has security support. See https://secure.php.net/supported-versions.php Both 5.6 & 7.0 have support to Dec 2018. Beyond that, you need 7.1+ (although 7.1 is not currently recommended for use with CiviCRM - https://docs.civicrm.org/sysadmin/en/latest/requirements/)

2) php 7 is faster than 5.6. See http://www.zend.com/en/resources/php7_infographic Why not run the faster version?

3) Maintaining support for old versions of php is a drain on development resources and prevents CiviCRM taking advantage of new php features.

So, yes upgrade to 7.0 now (providing you are on the current 4.7.* release) and expect to keep upgrading.

[Edit: prompted by Graham's comment.]

Php requirements links:

  • Would he useful to understand, in this context, what the level of support is for PHP 7 among the host CMS systems. Anyone got that detail handy?
    – Graham
    Feb 6, 2018 at 11:28
  • I am running 4.7.29 and keep that updated. But upon trying to upgrade , I ran into a problems. I am running Drupal 7 and do not know it very well. I tried to update to just 7.0 but I think I may have done it wrong and left some modules out. Feb 7, 2018 at 23:26
  • Check you have the php7 version of these modules: docs.civicrm.org/sysadmin/en/latest/requirements/…
    – Aidan
    Feb 8, 2018 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.