0

Upgrading seems to work fine, I checked folders and resources configuration because the paths weren't there anymore. Then when I try to access the extensions menu I get the following error :

Cannot read unrecognized property CRM_Core_Config::$defaultSymbol.

And the extensions list isn't being displayed. I tried turning debugging on but nothing shows

1

This is highly due to one of the custom extension enabled on your site. Few steps you could try to fix this -

  • Check if any of the extension overrides the file CRM/Core/Config.php. If you find it, move it outside the site dir and disable that extension after reloading the page.
  • Manually disable the extension from the database one by one and try to reload the page. To disable the ext, set is_active value to 0 in civicrm_extension table. (Remember to revert it back if the page reload is still an error).
  • Check if the custom php directory overrides the core file CRM/Core/Config.php. If yes, do the same as step 1.
  • Thanks for your answer. I searched for another Config.php in the whole project but didn't find anything. I deactivated all extensions in the db like you said, but it did not changed the error. Actually this errors shows up on the dashboard page also... The debugging shows : CRM_Core_Exception: Cannot read unrecognized property CRM_Core_Config::$defaultSymbol. in /web/pui/wp-content/plugins/files/civicrm/templates_c/fr_FR/%%24/24E/24E27851%%jsortable.tpl.php on line 152 – Pierre Feb 12 '18 at 13:22
  • Delete everything inside /web/pui/wp-content/plugins/files/civicrm/templates_c - they are only cache files. – Christian Wach Feb 12 '18 at 14:38
  • Agree with Christian - also try to rebuild the menu by appending this to the base URL - civicrm/menu/rebuild?reset=1 – jitendra - fuzion Feb 13 '18 at 2:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.