1

Running CiviCRM 5.10.4 and Drupal 7.65.

Trying to send out a bulk email through CiviMail using a checksum link for an event registration.

However when I insert the checksum link, I get an error message when CiviMail tries to autosave, or when I try to manually save:

Sorry an error occurred and your information was not saved

This is the checksum link I'm trying to insert

https://DOMAIN.com/civicrm/event/register?reset=1&id=89&cid={contact.contact_id}&{contact.checksum}

I've also tried with:

https://DOMAIN.com/civicrm/event/register?reset=1&id=89&{contact.checksum}&cid={contact.contact_id}

Have tried testing to save with every move I make when making the email, and have isolated the issue to only happening when I try to use these links (whether it's an image linked to this URL, or text).

I've checked and that is the correct event ID in the URL. I've tried inserting the link in the source code and in the WYSIWYG editor but neither are allowing me to save. I've tried writing out the URL in notepad and copying over from there in case any formatting is being pulled through somehow, but again no luck.

Any idea on where we're going wrong or how to fix this?

Cheers

EDIT: On more investigation, it allows me to save the email when I use the following link. However this creates an extra "cs=" in the URL so the checksums don't work....

The URL I've used this time is:

https://DOMAIN.com/civicrm/event/register?reset=1&id=89&cid={contact.contact_id}&cs={contact.checksum}
  • I can't reproduce on dmaster.demo.civicrm.org. Are you able to reproduce the error there? – Demerit Apr 8 at 4:35
  • @Demerit I wasn't able to reproduce it on that demo site either – josh Apr 8 at 5:02
  • Is upgrading an option for you? Are you able to test an upgrade on a copy of the site? – Demerit Apr 8 at 12:53
  • @Demerit do you mean upgrading to a newer version of CiviCRM? I've generally only been updating when a security update is necessary - but can give that a go as well. – josh Apr 9 at 23:43
  • Yes a newer vision of civi, since if it's not happening on the demo maybe upgrading will fix it by itself. – Demerit Apr 9 at 23:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.