2

I Have created a membership directory and it works fine when I am logged in but as soon as i log out I get this message -

The requested Profile (gid=1) is disabled OR it is not configured to be used for 'Profile' listings in its Settings OR there is no Profile with that ID OR you do not have permission to access this profile. Please contact the site administrator if you need assistance.

i am using Wordpress

Can someone advise me of a fix :(

Thanks ... I am new to CiviCRM

1

https://docs.civicrm.org/user/en/latest/organising-your-data/profiles/ has all the details you should need:

Visibility: If the Profile is being used for a searchable directory, set the Visibility of any fields you want to include on the search form to Public Pages or Public Pages and Listings. For fields that will be used on sign-up forms, set Visibility to User and User Admin only. This ensures that other visitors to the form can't view any data from the database. To use fields for Search Views, you must set Visibility to Public Pages or Public Pages and Listings. Choosing either of the Public Page options pops up two additional settings:

  • Many thanks for the prompt response ... I had already done that :( for the fields in the profile so its something else ... cheers – James Lindsay May 17 at 2:47
  • CMS permissions would be the only other thought then eg 'access all custom fields'? – petednz - fuzion May 17 at 5:20
  • oh, also you have said what settings you put on the Profile itself. I had perhaps wrongly assumed you were talking about the fields – petednz - fuzion May 17 at 5:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.