0

All of my CiviCRM profiles stopped being diplayed (via shortcode) without any Civi or PHP errors or warnings. This occurred with CiviCRM versions 5.41 and 5.43.2. Wordpress is 5.8.2.

This led to hours of extreme panic as GivingTuesday is around the corner and my donation profile was blank!

Has anyone else experienced this issue?

2
  • Hi Todd - thanks for sharing this. The format on SE is Q&A so to fit with that please rewrite this as a question describing the issues you were seeing and then add an answer with the resolution you found. It's fine to answer your own questions here!
    – Aidan
    Nov 25 at 10:35
  • 1
    Done! I wondered about that after my original post.
    – Todd Scott
    Nov 25 at 14:47
2

By deactivating my WordPress plugins, I found the issue was with the most recent All in One SEO plugin (version 4.1.5.2).

I have no idea why, but I did share this issue on the All in One SEO plugin support page.

1
  • Perhaps you can update your answer with the solutions given on the WordPress forum? Nov 25 at 17:07
1

Another solution from the All in One SEO plugin support page (Thanks, Christian!) was to add the following to my WP child theme's functions.php. This allowed me to keep re-activate the plugin:

add_filter( 'aioseo_conflicting_shortcodes', 'my_conflicting_shortcodes' );
function my_conflicting_shortcodes( $conflicting_shortcodes ) {
    $conflicting_shortcodes['CiviCRM'] = 'civicrm';
    return $conflicting_shortcodes;
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.