0

We have a Civi 4.4.14 installation. When choosing the Make mailing label action from search results 5 contacts are missing from the finished labels.

I've recreated the error on the 4.4 demo site but see that it is fixed in the 4.5 and 4.6 sites.

The site currently uses the civibooking extension which doesn't work with 4.5 or 4.6, so an upgrade isn't (currently) an option.

Does anyone have a patch/ fix for this?

Cheers

Craig

1

How are you trying to reproduce the problem? Are you just running a search and comparing the number of labels to the number of results? If so, you should expect to have fewer labels because CiviCRM will automatically exclude contacts with "do not mail".

If that's not the issue, try looking at what shared attributes the excluded contacts have. If it is a bug, an important step to replicate and fix the issue is to know what kinds of contacts go missing (or alternatively if it's a new random group dropped on each search run).

  • On the original database, all were Organisation contacts and found as a result of a specific advanced search- none were marked as do not mail. On the demo site I just looked for Individual members of one of the standard groups "advisory board" if I recall. I made a cursory inspection to check that none were marked as do not mail. Replicating the error was proof enough for me. I'll try and re-run in more detail next week. – Craig Almond Jul 24 '15 at 10:14
  • 1
    Okay, sounds buggier. How about the ones that are missing? Anything in common? I assume you've done at least a quick look at issues.civicrm.org--if it's a bug fixed for 4.5, you may have trouble finding it without knowing something about the contacts who get excluded from the labels. – Andrew Hunt Jul 24 '15 at 12:58
  • I have the same problem on a 4.5.8 CiviCRM on Drupal, I didn't find opened issues about this, do you have more info ? – Flo Oct 22 '15 at 15:33
  • Nothing that I know about. You should consider upgrading soon--4.5 is considered end-of-life at this point, so the most recent security release or two affect it but don't have fixed versions in the 4.5 series. But as to folks not appearing in labels, you really should start with identifying the contacts who are excluded and seeing if they have anything in common. – Andrew Hunt Oct 22 '15 at 15:46
  • OK I'll upgrade asap. But for the missing labels issue, on my system I couldn't find anything about the missing contacts, it's even more puzzling : contact A may be missing when printing labels from a search, but will be correctly printed from another search (typically searching on its exact name so it's the only one returned). So the context may be involved (bug depends on the set of contacts). I thought about contact field with incorrect characters screwing up the PDF but found nothing... – Flo Oct 24 '15 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.