1

I am using Drupal 9.3.9 (PHP 7.4.28), Stripe 6.7.1, mjwshared 1.2.2, sweetalert 1.5, Contribution cancel actions 5.41.1, firewall 1.5.1

turned off contributiontransactlegacy 1.5.1 as I understand its no longer needed or diesnt work with contributions/recurring?

I have membership set to £5 and also an optional contributions field (£10 - £10,000).

title tab use a confirmation page = no

amounts tab Contribution Amounts section enabled = yes Recurring Contributions = no (but I still have a contributions field showing ??) allow other amounts = yes

memberships tab Membership Section Enabled? = yes Require Membership Signup = no Separate Membership Payment = no (I did have set to yes but read that this will cause an issue with recurring payments with Stripe so now off) Display Membership Fee = yes

no profiles, widgets, premiums turned on

It does work for most people (including my membership) but certain banks (all UK based) that use an app to verify - the amount shows as zero so they cant proceed?

  • santander app says 0.00 and should be £20 (member paying £5 + £15 contribution)
  • HSBC app says £0.00 and should be £10 (member paying £5 + £5 contribution)

Maybe I should turn off the contribs part completely and take that separately as it could be messing with the recurring process?

3
  • Do you mean the authentication portal in the banks app shows the incorrect amount? Everything looks ok Civi wise? Apr 1, 2022 at 13:24
  • Yes - civicrm seems to display the right amount (just member fee or member fee plus contribution) and many people have paid successfully but depending on the customers bank - if they use a phone app as an extra security layer the app shows zero so they cant complete payment.
    – kevster
    Apr 6, 2022 at 11:12
  • Ok I would first upgrade to the latest versions of the stripe and dependent extensions. We’ve seen similar issues on sites and upgrades have resolved them. If that doesn’t work post back on here and we may be able to troubleshoot a few more things. Apr 7, 2022 at 6:21

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.