Using "upload package file" or "install from folder" on a clean new Joomla 3.5.1 installation without any other extension I get this error :

Cannot open mysql://XXX:YYY@localhost/XXX?new_link=true: DB Error: extension not found

Tried 4.7.7 and for testing even CiviCRM 4.6.16 LTS -> same error

PHP Built On Linux dd36620 3.13.0-85-generic #129-Ubuntu SMP Thu Mar 17 20:50:15 UTC 2016 x86_64

Database Version mysqli 5.6.27-nmm1-log

Database Collation latin1_swedish_ci

Database Connection Collation utf8mb4_general_ci

PHP Version 7.0.4-nmm1

Web Server Apache

WebServer to PHP Interface fpm-fcgi

Joomla! Version Joomla! 3.5.1 Stable [ Unicorn ] 05-April-2016 22:45 GMT

Joomla! Platform Version Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT

User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36

Tried as suggested in the WIKI

php_value memory_limit 128M

php_value register_globals off

php_value max_execution_time 600

Maybe someone has an idea what I could do to get it installed, thanks

1 Answer 1


Have you installed php-mysql?

sudo apt-get install php-mysql

To me, it sounds like PHP doesn't have the MySQL extension installed.

Meanwhile, at this point, CiviCRM doesn't support PHP 7, so if you do get this working, you'll run into that problem next.

  • the cms runs on a web space reseller, I can't apt-get packages. Is there a way for me to check for php-mysql ? PHP 7 is not a big problem, I can .htaccess it to 5.6
    – Paul
    Commented May 6, 2016 at 22:05
  • It still may be that your PHP is missing the MySQL extension--it may simply be something to handle in your settings files then.
    – Andie Hunt
    Commented May 6, 2016 at 22:39
  • 3
    CiviCRM is not yet supported on PHP7 (question, CRM-17789). PHP7 has removed the deprecated mysql extension. Downgrade to PHP5.6 until CiviCRM is supported on PHP7. Commented Jun 6, 2016 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.