5

On an Ubuntu 16.04 VM with PHP 7.x, I am seeing the following error when enabling CiviCRM in Drupal 7:

ParseError: syntax error, unexpected 'clone' (T_CLONE), expecting identifier (T_STRING) or '(' in require_once() (line 1 of /home/westernfriend/public_html/sites/all/modules/civicrm/packages/DB/DataObject.php(207) : eval()'d code).

Is this due to incompatibility with PHP 7, a missing dependency, or perhaps something else?

  • I just wanted to drop in and say thanks. Installing LTS (at the time not uo to PHP 7.0) and wondering why I was getting error after error. Fighting Index location and PHP Parse errors to no avail.... now I know why... too smart to read the docs first... duh. Thanks. – Timothy W. Crane Nov 12 '17 at 7:15
7

PHP 7 is not supported yet - see CRM-17789

Also: this and this

Update (Aug 2017): The information above was correct when it was written. Things have moved on and PHP 7.0 is supported from 4.7.12 onwards. Earlier versions of 4.7 don't run on PHP 7.0 and nor does any released version of 4.6. There are discussions about adding this to 4.6 - see the same ticket.

The most current information should be on CiviCRM PHP Requirements

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.