4

When attempting to upgrade from CiviCRM 4.6.16 to any of the 4.7 releases, I receive the following error message:

Error: Migrate "on behalf of" information to module_data

Debug info says: "Unknown column 'for_organization' in 'field_list'

This is the first time I've encountered any issues during the upgrade process. I have been using CiviCRM since version 4.4.

Screenshot is below. Thank you for your help! Darron

Error message screenshot

  • I'm not seeing you received any help for this. I'm also struggling with the upgrade process. I did find some help elsewhere. Although it wasn't sufficient - perhaps it would help you. It is possible you might have Drupal DB updates to execute before hand. I'm not using drush - but I did find some updates were needed when I checked the status report. forum.civicrm.org/index.php?topic=37002.0 – Harold Shinsato Sep 5 '16 at 23:28
1

Problem is old field was lost in the upgrade. Try updating this file:

CRM/Upgrade/Incremental/php/FourSeven.php

with code at this GIT pull request.

This post here explains it in more detail.

  • As a reminder, Stack Exchange frowns upon answers consisting of only a link; such answers may be deleted at any time. You should provide a summary or excerpt of the concept available at the link, particularly as external URLs are unstable and may become unavailable over time. – choster May 31 '18 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.