0

WordPress 4.6.26 Civi 4.7.3 iATS for Payment Processing

Beginning in Jan we started hearing from donors that when they set up donations they would get a 9002 Error when they clicked Confirm. So far it appears to be ACH transactions that are having trouble.

The iATS Request Log for these donations looks the same as all others. However, the iATS Response Log does not have anything in the auth_result field.

The first time this happened, I attempted entering the donor's account info for them and got the same results. 20 minutes later it went through with no error.

The other cases have processed the first attempt for me but I can see in the Response Log that they tried several times with no auth_results data. I have another one right now that the donor tried 2 days in a row and got the 9002 Error. I have not tried to do it yet because I was hoping to do some trouble shooting first.

At least two of the donors were using Google Chrome for their browser. I have not seen any problems with any browsers except IE.

How to get IATS working It is about someone else getting the 9002 Error (but theirs was constant). I changed to Karin's https://www2.iatspayments.com/NetGate/ProcessLinkv2.asmx?WSDL and donations are still processing. Just for clarification, does any one know: 1. What are the special characters to avoid? 2. Is this in our password with iATS/Civi or is this in the donor's password? 3. Is there a list of potential "misconfiguration" issues out there somewhere that I can go over?

Does anyone have any other ideas for troubleshooting the sporadic loss in communications? Are there other logs that would show if Civi actually sent the request or that show if iATS received the request?

  • We upgraded Civi to 4.7.17 and tried to run the donation again. I still got the 9002 Error. But this time the donation shows as Pending in the reports and Donor Dashboard. It did not create a recurring contribution for it and I'm sure I had checked that box. – Iowa Boy Mar 16 '17 at 17:24
  • The donation in my above comment did not process. It just stayed as Pending. The upgrade did not seem to fix anything. – Iowa Boy Apr 3 '17 at 21:25
0

Intermittent issues can be difficult to diagnose. A couple of notes that may help:

What you really need to do is to get TLS 1.2 and switch back to the www server. The www2 server is only needed for those not at the TLS 1.2 standard yet and is going to go away. Your lack of TLS 1.2 is probably a symptom of a system that is not up to date or maintained, that could well be the key issue.

Avoid any special characters in your iATS 80 account password; If you're using another than 80 account w/ iATS then confirm with customer services that you can deposit monies into that account via WebServices. If you're using more than one iATS subaccount 80, 81, 82 etc confirm all are able to accept monies via WebServices.

  • Thanks Karin, I did end up switching back to the non-www2 link because our ACH contributions were not processing. I have tried the plain link and the link with v2 in it. The plain link is what we had when the problem started. Does that mean we are TLS 1.2? I checked our password and it does not have special characters. – Iowa Boy Mar 12 '17 at 22:10
  • I tried to do the donation again today with her ACH info and got the same error. I tried it as not recurring, I added two 00s in front of the bank account # to make it longer, and I still got the error. I entered my bank account info and it processed without a problem. – Iowa Boy Mar 16 '17 at 1:24
  • Ok so it IS working with your own ACH details just not for her ACH info? Best to contact iATS Customer Service - and check with them on this US Bank routing/details. – KarinG - Semper IT Apr 5 '17 at 15:31
  • Karin, See my answer above. The account and routing was correct. – Iowa Boy Apr 6 '17 at 21:15
0

I think we found the problem(s). We connected with Trustwave and they have a PCI compliance scan. I ran the scan on our website and it revealed some issues. We worked with our web-host to correct those server setup issues. We re-ran the scan and the issues were gone.

As Karin said, intermittent issues are hard to track. But we had one donor who always got the 9002 error (we tried it after every "fix"). After passing the Trustwave PCI scan, I tried the "consistently failing" donation again and it went through no problem.

Even if everyone (web-host, payment processor, etc) says they are PCI compliant, I would suggest you run a compliance scan to be sure. If nothing else, it can be a great troubleshooting tool for an intermittent processing issue.

  • Can you share specific PCI compliance problems that you resolved? – Jamie Oct 26 '18 at 19:35
  • I just read back through the emails and i am not sure exactly what was done. We were working with support at our webhost. They were writing firewall rules and changing settings and then telling me to run another compliance scan. It took some backforth over several days for them to get their firewall rules and settings dialed in. Wish I could be of more service. – Iowa Boy Oct 27 '18 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.